aboutsummaryrefslogtreecommitdiff
path: root/textproc/clucene-qt5/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/clucene-qt5/Makefile')
-rw-r--r--textproc/clucene-qt5/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/textproc/clucene-qt5/Makefile b/textproc/clucene-qt5/Makefile
new file mode 100644
index 000000000000..c9b895c8d9ed
--- /dev/null
+++ b/textproc/clucene-qt5/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= clucene
+DISTVERSION= ${QT5_VERSION}
+CATEGORIES= textproc
+PKGNAMEPREFIX= qt5-
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt bindings for the CLucene full-text search library
+
+USE_QT5= core buildtools_build
+QT_DIST= tools
+USES= qmake
+USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
+
+WRKSRC_SUBDIR= src/assistant/${PORTNAME}
+PATCH_WRKSRC= ${WRKSRC:H}
+
+.include <bsd.port.mk>