aboutsummaryrefslogtreecommitdiff
path: root/textproc/ctpp
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/ctpp')
-rw-r--r--textproc/ctpp/Makefile5
-rw-r--r--textproc/ctpp/distinfo4
-rw-r--r--textproc/ctpp/files/patch-Makefile.in26
-rw-r--r--textproc/ctpp/pkg-plist75
4 files changed, 107 insertions, 3 deletions
diff --git a/textproc/ctpp/Makefile b/textproc/ctpp/Makefile
index 095157ea88c8..ab6204ca853a 100644
--- a/textproc/ctpp/Makefile
+++ b/textproc/ctpp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ctpp
-PORTVERSION= 1.7
+PORTVERSION= 1.7.5
CATEGORIES= textproc devel
MASTER_SITES= http://www.reki.ru/products/ctpp/download/
@@ -26,4 +26,7 @@ CONFIGURE_ARGS+= --enable-optimization
CONFIGURE_ARGS+= --enable-debug
.endif
+post-patch:
+ @${RM} -f ${WRKSRC}/obj/*.o
+
.include <bsd.port.mk>
diff --git a/textproc/ctpp/distinfo b/textproc/ctpp/distinfo
index a5b7a8398c46..9bfcaf926917 100644
--- a/textproc/ctpp/distinfo
+++ b/textproc/ctpp/distinfo
@@ -1,2 +1,2 @@
-MD5 (ctpp-1.7.tar.gz) = df13141fefeda701d6c566b886829494
-SIZE (ctpp-1.7.tar.gz) = 125951
+MD5 (ctpp-1.7.5.tar.gz) = 3d82e2cf6a4d90e7920f6aa6ba90c963
+SIZE (ctpp-1.7.5.tar.gz) = 269277
diff --git a/textproc/ctpp/files/patch-Makefile.in b/textproc/ctpp/files/patch-Makefile.in
new file mode 100644
index 000000000000..8e01d4a45b2e
--- /dev/null
+++ b/textproc/ctpp/files/patch-Makefile.in
@@ -0,0 +1,26 @@
+--- Makefile.in.orig Wed Feb 9 11:50:31 2005
++++ Makefile.in Wed Feb 9 22:09:28 2005
+@@ -75,8 +75,8 @@
+ fi; \
+ done;
+ @echo -------------------------------------- Installing documentation ----------
+- if test ! -d "$(PREFIX)/doc"; then \
+- $(INSTALL) -d -m 0755 $(PREFIX)/doc; \
++ if test ! -d "$(PREFIX)/share/doc"; then \
++ $(INSTALL) -d -m 0755 $(PREFIX)/share/doc; \
+ fi; \
+ ELEM_LIST=`ls -R -1 $(BUILDROOT)/doc | sed 's!:$$!!';` ; \
+ CURR_DIR=''; \
+@@ -85,10 +85,10 @@
+ EXCL_PATH=`echo $(BUILDROOT)/doc | sed 's!\.!\\\\.!g'`; \
+ INST_PATH=`eval "echo $$ELEMENT | sed 's!^$$EXCL_PATH!!g'"`; \
+ CURR_DIR=$$ELEMENT; \
+- $(INSTALL) -d -m 0755 $(PREFIX)/doc/$$INST_PATH; \
++ $(INSTALL) -d -m 0755 $(PREFIX)/share/doc/ctpp/$$INST_PATH; \
+ else \
+ if test -f "$$CURR_DIR/$$ELEMENT"; then \
+- $(INSTALL) -m 0644 $$CURR_DIR/$$ELEMENT $(PREFIX)/doc/$$INST_PATH/$$ELEMENT; \
++ $(INSTALL) -m 0644 $$CURR_DIR/$$ELEMENT $(PREFIX)/share/doc/ctpp/$$INST_PATH/$$ELEMENT; \
+ fi; \
+ fi; \
+ done;
diff --git a/textproc/ctpp/pkg-plist b/textproc/ctpp/pkg-plist
index 5ae08a8a3053..b5231d54ef51 100644
--- a/textproc/ctpp/pkg-plist
+++ b/textproc/ctpp/pkg-plist
@@ -15,7 +15,82 @@ include/ctpp/functions/value_in_set.hpp
include/ctpp/util/d2str.hpp
lib/libctpp.so
lib/libctpp.a
+share/doc/ctpp/en/ctpp.chm
+share/doc/ctpp/en/html/ctpp_compile.html
+share/doc/ctpp/en/html/ctpp_context_vars.html
+share/doc/ctpp/en/html/ctpp_cover.html
+share/doc/ctpp/en/html/ctpp.css
+share/doc/ctpp/en/html/ctpp_def.html
+share/doc/ctpp/en/html/ctpp_dev_algorithm.html
+share/doc/ctpp/en/html/ctpp_dev_api.html
+share/doc/ctpp/en/html/ctpp_dev_intro.html
+share/doc/ctpp/en/html/ctpp_dev_sample.html
+share/doc/ctpp/en/html/ctpp_dev_udf.html
+share/doc/ctpp/en/html/ctpp_errors.html
+share/doc/ctpp/en/html/ctpp_function_form_param.html
+share/doc/ctpp/en/html/ctpp_function_href_param.html
+share/doc/ctpp/en/html/ctpp_function_htmlescape.html
+share/doc/ctpp/en/html/ctpp_function_in_set.html
+share/doc/ctpp/en/html/ctpp_function_is_a.html
+share/doc/ctpp/en/html/ctpp_function_num_format.html
+share/doc/ctpp/en/html/ctpp_function_re.html
+share/doc/ctpp/en/html/ctpp_function_sprintf.html
+share/doc/ctpp/en/html/ctpp_function_urlescape.html
+share/doc/ctpp/en/html/ctpp.hhc
+share/doc/ctpp/en/html/ctpp.hhk
+share/doc/ctpp/en/html/ctpp.hhp
+share/doc/ctpp/en/html/ctpp_intro.html
+share/doc/ctpp/en/html/ctpp_license.html
+share/doc/ctpp/en/html/ctpp_operators.html
+share/doc/ctpp/en/html/ctpp_thanks.html
+share/doc/ctpp/en/html/ctpp_tmpl_if.html
+share/doc/ctpp/en/html/ctpp_tmpl_include.html
+share/doc/ctpp/en/html/ctpp_tmpl_loop.html
+share/doc/ctpp/en/html/ctpp_tmpl_udf.html
+share/doc/ctpp/en/html/ctpp_tmpl_var.html
+share/doc/ctpp/en/html/index.html
+share/doc/ctpp/en/html/index_left.html
+share/doc/ctpp/ru/ctpp.chm
+share/doc/ctpp/ru/html/ctpp_compile.html
+share/doc/ctpp/ru/html/ctpp_context_vars.html
+share/doc/ctpp/ru/html/ctpp_cover.html
+share/doc/ctpp/ru/html/ctpp.css
+share/doc/ctpp/ru/html/ctpp_def.html
+share/doc/ctpp/ru/html/ctpp_dev_algorithm.html
+share/doc/ctpp/ru/html/ctpp_dev_api.html
+share/doc/ctpp/ru/html/ctpp_dev_intro.html
+share/doc/ctpp/ru/html/ctpp_dev_sample.html
+share/doc/ctpp/ru/html/ctpp_dev_udf.html
+share/doc/ctpp/ru/html/ctpp_errors.html
+share/doc/ctpp/ru/html/ctpp_function_form_param.html
+share/doc/ctpp/ru/html/ctpp_function_href_param.html
+share/doc/ctpp/ru/html/ctpp_function_htmlescape.html
+share/doc/ctpp/ru/html/ctpp_function_in_set.html
+share/doc/ctpp/ru/html/ctpp_function_is_a.html
+share/doc/ctpp/ru/html/ctpp_function_num_format.html
+share/doc/ctpp/ru/html/ctpp_function_re.html
+share/doc/ctpp/ru/html/ctpp_function_sprintf.html
+share/doc/ctpp/ru/html/ctpp_function_urlescape.html
+share/doc/ctpp/ru/html/ctpp.hhc
+share/doc/ctpp/ru/html/ctpp.hhk
+share/doc/ctpp/ru/html/ctpp.hhp
+share/doc/ctpp/ru/html/ctpp_intro.html
+share/doc/ctpp/ru/html/ctpp_license.html
+share/doc/ctpp/ru/html/ctpp_operators.html
+share/doc/ctpp/ru/html/ctpp_thanks.html
+share/doc/ctpp/ru/html/ctpp_tmpl_if.html
+share/doc/ctpp/ru/html/ctpp_tmpl_include.html
+share/doc/ctpp/ru/html/ctpp_tmpl_loop.html
+share/doc/ctpp/ru/html/ctpp_tmpl_udf.html
+share/doc/ctpp/ru/html/ctpp_tmpl_var.html
+share/doc/ctpp/ru/html/index.html
+share/doc/ctpp/ru/html/index_left.html
@dirrm include/ctpp/util
@dirrm include/ctpp/functions
@dirrm include/ctpp/ctpp
@dirrm include/ctpp
+@dirrm share/doc/ctpp/en/html
+@dirrm share/doc/ctpp/en
+@dirrm share/doc/ctpp/ru/html
+@dirrm share/doc/ctpp/ru
+@dirrm share/doc/ctpp