aboutsummaryrefslogtreecommitdiff
path: root/textproc/doclifter/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/doclifter/Makefile')
-rw-r--r--textproc/doclifter/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/textproc/doclifter/Makefile b/textproc/doclifter/Makefile
new file mode 100644
index 000000000000..40f198f0e9b2
--- /dev/null
+++ b/textproc/doclifter/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: doclifter
+# Date created: Apr 1, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= doclifter
+PORTVERSION= 1.0.4
+CATEGORIES= textproc
+MASTER_SITES= http://www.catb.org/~esr/doclifter/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Translates documents written in troff macros to DocBook
+
+USE_REINPLACE= yes
+USE_PYTHON= yes
+NO_BUILD= yes
+
+MAN1= doclifter.1
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,python2,${PYTHON_CMD},g" ${WRKSRC}/doclifter
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/doclifter ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doclifter.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>