aboutsummaryrefslogtreecommitdiff
path: root/textproc/etoile-lucenekit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/etoile-lucenekit/Makefile')
-rw-r--r--textproc/etoile-lucenekit/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/textproc/etoile-lucenekit/Makefile b/textproc/etoile-lucenekit/Makefile
new file mode 100644
index 000000000000..3cac57497f41
--- /dev/null
+++ b/textproc/etoile-lucenekit/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: etoile-lucenekit
+# Date created: 14 Dec 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= lucenekit
+PORTVERSION= 0.1.${SNAPSHOT}
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_GNUSTEP_CH}
+PKGNAMEPREFIX= etoile-
+DISTNAME= etoile_0+${SNAPSHOT}+dfsg.orig
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Etoile Project OgreKit framework
+
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+USE_GNUSTEP_LOCAL_LIBS+= OgreKit:${OGREKIT_PORT}
+USE_GNUSTEP_LDCONFIG= ${SYSLIBDIR}
+
+SNAPSHOT= 20060917
+WRKSRC= ${WRKDIR}/etoile-0+${SNAPSHOT}+dfsg/Etoile/
+USE_GNUSTEP_MAKE_DIRS+= Frameworks/LuceneKit
+
+OGREKIT_PORT?= textproc/etoile-ogrekit
+
+.include <bsd.port.mk>