aboutsummaryrefslogtreecommitdiff
path: root/textproc/flex
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/flex')
-rw-r--r--textproc/flex/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/textproc/flex/Makefile b/textproc/flex/Makefile
index 46482481200c..e07c8b6782be 100644
--- a/textproc/flex/Makefile
+++ b/textproc/flex/Makefile
@@ -7,7 +7,7 @@
PORTNAME= flex
PORTVERSION= 2.5.35
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -24,12 +24,15 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-nls --includedir=${PREFIX}/include/flex
USE_GMAKE= yes
MAN1= flex.1
+INFO= flex
PLIST_FILES= bin/flex include/flex/FlexLexer.h lib/libfl.a lib/libfl_pic.a
PLIST_DIRS= include/flex
-post-patch:
- @${REINPLACE_CMD} -e 's/install-info-recursive//g;s/info-recursive//g' \
+post-patch: .SILENT
+ ${REINPLACE_CMD} \
-e 's/po //;s/tests//' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's/ install-info-am//' ${WRKSRC}/doc/Makefile.in
+ ${REINPLACE_CMD} 's/@MAKEINFO@/& --no-split/g' \
+ ${WRKSRC}/doc/Makefile.in
+ ${RM} -f ${WRKSRC}/doc/*.info*
.include <bsd.port.mk>