aboutsummaryrefslogtreecommitdiff
path: root/textproc/gladtex/files/patch-Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/gladtex/files/patch-Makefile')
-rw-r--r--textproc/gladtex/files/patch-Makefile24
1 files changed, 13 insertions, 11 deletions
diff --git a/textproc/gladtex/files/patch-Makefile b/textproc/gladtex/files/patch-Makefile
index af539c45f66f..62033e295e74 100644
--- a/textproc/gladtex/files/patch-Makefile
+++ b/textproc/gladtex/files/patch-Makefile
@@ -1,20 +1,22 @@
-$FreeBSD$
---- Makefile Wed Oct 30 13:24:34 2002
-+++ Makefile.port Sat Feb 4 21:43:23 2006
-@@ -1,14 +1,17 @@
+--- ./Makefile.orig 2012-05-01 18:11:56.000000000 +0200
++++ ./Makefile 2012-05-01 18:15:04.000000000 +0200
+@@ -1,18 +1,19 @@
+ # Makefile for gladtex
+
-BINPATH = /usr/local/bin
+-MANPATH = /usr/local/share/man/man1
+BINPATH?= /usr/local/bin
-+LIBPATH?= /usr/local/lib
-+INCPATH?= /usr/local/include
++MANPATH?= /usr/local/share/man/man1
-CC = gcc -O2 -DGIF
--LIB = -lm -lz -lungif -lpng
+-LIB = -lm -lz -lgif -lpng
+CC = gcc
+CFLAGS+= -DGIF ${INCPATH}
-+LIB = -lm -lz ${LIBPATH} -lungif -lpng
++LIB = -lm -lz ${LIBPATH} -lgif -lpng
OBJ = eqn2img.o
+ POD2MAN = pod2man
- all: ${OBJ}
+ all: ${OBJ} gladtex.1
- ${CC} -o eqn2img ${LIB} ${OBJ}
+ ${CC} ${CFLAGS} -o eqn2img ${LIB} ${OBJ}
@@ -22,5 +24,5 @@ $FreeBSD$
- ${CC} -c eqn2img.c
+ ${CC} ${CFLAGS} -c eqn2img.c
- install: all
- install -m 755 -s eqn2img ${BINPATH}
+ gladtex.1: gladtex.pod
+ ${POD2MAN} -c "User Commands" -r "gladtex 1.2" gladtex.pod > gladtex.1