aboutsummaryrefslogtreecommitdiff
path: root/textproc/gnugrep/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/gnugrep/Makefile')
-rw-r--r--textproc/gnugrep/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/textproc/gnugrep/Makefile b/textproc/gnugrep/Makefile
new file mode 100644
index 000000000000..0d0df07fd801
--- /dev/null
+++ b/textproc/gnugrep/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: grep
+# Date created: 5 February 2010
+# Whom: Gabor Kovesdan <gabor@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= grep
+PORTVERSION= 2.5.4
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= gnu
+
+MAINTAINER= gabor@FreeBSD.org
+COMMENT= GNU grep
+
+GNU_CONFIGURE= yes
+MAN1= egrep.1 \
+ fgrep.1 \
+ grep.1
+INFO= grep
+PLIST_FILES= bin/egrep \
+ bin/fgrep \
+ bin/grep
+
+OPTIONS= PCRE "Compile with Perl-compatible regex support" off
+
+CONFLICTS= bsd-grep-*
+
+.include <bsd.port.pre.mk>
+
+CONFIGURE_ARGS+= --disable-nls
+
+.if defined(WITH_PCRE)
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+.else
+CONFIGURE_ARGS+= --disable-perl-regexp
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} 's|mkinstalldirs = .*|mkinstalldirs = mkdir -p|g' \
+ ${WRKSRC}/intl/Makefile.in
+
+.include <bsd.port.post.mk>