aboutsummaryrefslogtreecommitdiff
path: root/textproc/gtkspell3
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/gtkspell3')
-rw-r--r--textproc/gtkspell3/Makefile28
-rw-r--r--textproc/gtkspell3/distinfo2
-rw-r--r--textproc/gtkspell3/pkg-descr5
-rw-r--r--textproc/gtkspell3/pkg-plist98
4 files changed, 133 insertions, 0 deletions
diff --git a/textproc/gtkspell3/Makefile b/textproc/gtkspell3/Makefile
new file mode 100644
index 000000000000..4a78242bd69c
--- /dev/null
+++ b/textproc/gtkspell3/Makefile
@@ -0,0 +1,28 @@
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= gtkspell3
+PORTVERSION= 3.0.4
+CATEGORIES= textproc gnome
+MASTER_SITES= SF/gtkspell/${PORTVERSION}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GTK+ 3 spell checking component
+
+BUILD_DEPENDS= vapigen:${PORTSDIR}/lang/vala-vapigen
+LIB_DEPENDS= libenchant.so:${PORTSDIR}/textproc/enchant
+
+USE_GNOME= gnomehier gnomeprefix gtk30 intlhack introspection:build
+USES= gettext gmake libtool pathfix pkgconfig
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^SUBDIRS/ s|docs||' ${WRKSRC}/Makefile.in
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgtkspell3-3.so.*
+
+.include <bsd.port.mk>
diff --git a/textproc/gtkspell3/distinfo b/textproc/gtkspell3/distinfo
new file mode 100644
index 000000000000..ff33692e2334
--- /dev/null
+++ b/textproc/gtkspell3/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gtkspell3-3.0.4.tar.gz) = fabf8e670c99c1a91996e0e33fa78b7c023f77efb3e11355cf5aa9bcdc43e4a7
+SIZE (gtkspell3-3.0.4.tar.gz) = 420762
diff --git a/textproc/gtkspell3/pkg-descr b/textproc/gtkspell3/pkg-descr
new file mode 100644
index 000000000000..05f8488a91d8
--- /dev/null
+++ b/textproc/gtkspell3/pkg-descr
@@ -0,0 +1,5 @@
+GtkSpell provides MSWord/MacOSX-style highlighting of misspelled words in a
+GtkTextView widget as you type. Right-clicking a misspelled word pops up a menu
+of suggested replacements.
+
+WWW: http://gtkspell.sourceforge.net/
diff --git a/textproc/gtkspell3/pkg-plist b/textproc/gtkspell3/pkg-plist
new file mode 100644
index 000000000000..002e3969320b
--- /dev/null
+++ b/textproc/gtkspell3/pkg-plist
@@ -0,0 +1,98 @@
+include/gtkspell-3.0/gtkspell/gtkspell.h
+lib/girepository-1.0/GtkSpell-3.0.typelib
+lib/libgtkspell3-3.a
+lib/libgtkspell3-3.la
+lib/libgtkspell3-3.so
+lib/libgtkspell3-3.so.0
+lib/libgtkspell3-3.so.0.1.0
+libdata/pkgconfig/gtkspell3-3.0.pc
+share/gir-1.0/GtkSpell-3.0.gir
+share/locale/af/LC_MESSAGES/gtkspell3.mo
+share/locale/ak/LC_MESSAGES/gtkspell3.mo
+share/locale/ast/LC_MESSAGES/gtkspell3.mo
+share/locale/be/LC_MESSAGES/gtkspell3.mo
+share/locale/cs/LC_MESSAGES/gtkspell3.mo
+share/locale/da/LC_MESSAGES/gtkspell3.mo
+share/locale/de/LC_MESSAGES/gtkspell3.mo
+share/locale/el/LC_MESSAGES/gtkspell3.mo
+share/locale/eo/LC_MESSAGES/gtkspell3.mo
+share/locale/es/LC_MESSAGES/gtkspell3.mo
+share/locale/eu/LC_MESSAGES/gtkspell3.mo
+share/locale/ff/LC_MESSAGES/gtkspell3.mo
+share/locale/fi/LC_MESSAGES/gtkspell3.mo
+share/locale/fo/LC_MESSAGES/gtkspell3.mo
+share/locale/fr/LC_MESSAGES/gtkspell3.mo
+share/locale/ga/LC_MESSAGES/gtkspell3.mo
+share/locale/gl/LC_MESSAGES/gtkspell3.mo
+share/locale/he/LC_MESSAGES/gtkspell3.mo
+share/locale/hr/LC_MESSAGES/gtkspell3.mo
+share/locale/hu/LC_MESSAGES/gtkspell3.mo
+share/locale/hy/LC_MESSAGES/gtkspell3.mo
+share/locale/id/LC_MESSAGES/gtkspell3.mo
+share/locale/is/LC_MESSAGES/gtkspell3.mo
+share/locale/it/LC_MESSAGES/gtkspell3.mo
+share/locale/ja/LC_MESSAGES/gtkspell3.mo
+share/locale/ky/LC_MESSAGES/gtkspell3.mo
+share/locale/lg/LC_MESSAGES/gtkspell3.mo
+share/locale/lt/LC_MESSAGES/gtkspell3.mo
+share/locale/lv/LC_MESSAGES/gtkspell3.mo
+share/locale/mn/LC_MESSAGES/gtkspell3.mo
+share/locale/ms/LC_MESSAGES/gtkspell3.mo
+share/locale/nb/LC_MESSAGES/gtkspell3.mo
+share/locale/nl/LC_MESSAGES/gtkspell3.mo
+share/locale/nso/LC_MESSAGES/gtkspell3.mo
+share/locale/pl/LC_MESSAGES/gtkspell3.mo
+share/locale/pt/LC_MESSAGES/gtkspell3.mo
+share/locale/pt_BR/LC_MESSAGES/gtkspell3.mo
+share/locale/rm/LC_MESSAGES/gtkspell3.mo
+share/locale/ro/LC_MESSAGES/gtkspell3.mo
+share/locale/ru/LC_MESSAGES/gtkspell3.mo
+share/locale/rw/LC_MESSAGES/gtkspell3.mo
+share/locale/sk/LC_MESSAGES/gtkspell3.mo
+share/locale/sl/LC_MESSAGES/gtkspell3.mo
+share/locale/son/LC_MESSAGES/gtkspell3.mo
+share/locale/sq/LC_MESSAGES/gtkspell3.mo
+share/locale/sr/LC_MESSAGES/gtkspell3.mo
+share/locale/st/LC_MESSAGES/gtkspell3.mo
+share/locale/sv/LC_MESSAGES/gtkspell3.mo
+share/locale/th/LC_MESSAGES/gtkspell3.mo
+share/locale/tr/LC_MESSAGES/gtkspell3.mo
+share/locale/uk/LC_MESSAGES/gtkspell3.mo
+share/locale/vi/LC_MESSAGES/gtkspell3.mo
+share/locale/wa/LC_MESSAGES/gtkspell3.mo
+share/locale/zh_CN/LC_MESSAGES/gtkspell3.mo
+share/locale/zh_HK/LC_MESSAGES/gtkspell3.mo
+share/locale/zh_TW/LC_MESSAGES/gtkspell3.mo
+share/locale/zu/LC_MESSAGES/gtkspell3.mo
+share/vala/vapi/gtkspell3-3.0.deps
+share/vala/vapi/gtkspell3-3.0.vapi
+@dirrmtry share/locale/zu/LC_MESSAGES
+@dirrmtry share/locale/zu
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/st/LC_MESSAGES
+@dirrmtry share/locale/st
+@dirrmtry share/locale/son/LC_MESSAGES
+@dirrmtry share/locale/son
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/rm/LC_MESSAGES
+@dirrmtry share/locale/rm
+@dirrmtry share/locale/nso/LC_MESSAGES
+@dirrmtry share/locale/nso
+@dirrmtry share/locale/lg/LC_MESSAGES
+@dirrmtry share/locale/lg
+@dirrmtry share/locale/ky/LC_MESSAGES
+@dirrmtry share/locale/ky
+@dirrmtry share/locale/hy/LC_MESSAGES
+@dirrmtry share/locale/hy
+@dirrmtry share/locale/fo/LC_MESSAGES
+@dirrmtry share/locale/fo
+@dirrmtry share/locale/ff/LC_MESSAGES
+@dirrmtry share/locale/ff
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
+@dirrmtry share/locale/ak/LC_MESSAGES
+@dirrmtry share/locale/ak
+@dirrm include/gtkspell-3.0/gtkspell
+@dirrm include/gtkspell-3.0