aboutsummaryrefslogtreecommitdiff
path: root/textproc/hs-lhs2tex/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/hs-lhs2tex/Makefile')
-rw-r--r--textproc/hs-lhs2tex/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/textproc/hs-lhs2tex/Makefile b/textproc/hs-lhs2tex/Makefile
new file mode 100644
index 000000000000..aa810f27be74
--- /dev/null
+++ b/textproc/hs-lhs2tex/Makefile
@@ -0,0 +1,36 @@
+# ex:ts=8
+# Ports collection makefile for: lhs2TeX
+# Date created: April 24, 2007
+# Whom: mainland@apeiron.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= lhs2tex
+PORTVERSION= 1.12
+CATEGORIES= devel haskell
+MASTER_SITES= http://www.informatik.uni-bonn.de/~loeh/${PORTNAME}/
+
+MAINTAINER= mainland@apeiron.net
+COMMENT= A preprocessor to generate LaTeX code from literate Haskell sources
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
+ mktexlsr:${PORTSDIR}/print/teTeX-base
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --datadir=${DATADIR} \
+ --docdir=${DOCSDIR} \
+ --mandir=${MANPREFIX}/man
+
+.if defined(NOPORTDOCS)
+INSTALL_TARGET=install
+.else
+INSTALL_TARGET=install install-doc
+.endif
+
+MAN1= lhs2TeX.1
+
+.include <bsd.port.mk>