aboutsummaryrefslogtreecommitdiff
path: root/textproc/hs-texmath/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/hs-texmath/Makefile')
-rw-r--r--textproc/hs-texmath/Makefile74
1 files changed, 4 insertions, 70 deletions
diff --git a/textproc/hs-texmath/Makefile b/textproc/hs-texmath/Makefile
index fb4f6fbe1e35..0cbad2d893e9 100644
--- a/textproc/hs-texmath/Makefile
+++ b/textproc/hs-texmath/Makefile
@@ -8,82 +8,16 @@
PORTNAME= texmath
PORTVERSION= 0.1.1
CATEGORIES= textproc haskell
-MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
-PKGNAMEPREFIX= hs-
MAINTAINER= jacula@gmail.com
COMMENT= Conversion of LaTeX math formulas to MathML for Haskell
-BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
- hs-xml>=1.2.6:${PORTSDIR}/textproc/hs-xml \
- hs-cgi>=3001.1.7.1:${PORTSDIR}/www/hs-cgi \
- hs-json>=0.4.3:${PORTSDIR}/converters/hs-json
-RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
- hs-xml>=1.2.6:${PORTSDIR}/textproc/hs-xml \
- hs-cgi>=3001.1.7.1:${PORTSDIR}/www/hs-cgi \
- hs-json>=0.4.3:${PORTSDIR}/converters/hs-json
+CABAL_SETUP= Setup.hs
+USE_HACKAGE= cgi json xml
-GHC_VERSION= 6.10.4
-TEXMATH_VERSION= ${PORTVERSION}
+EXECUTABLE= testTeXMathML texmath-cgi
-GHC_CMD= ${LOCALBASE}/bin/ghc
-SETUP_CMD= ./setup
-
-DATADIR= ${PREFIX}/share/${DISTNAME}
PORTDATA= *
-DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
-TEXMATH_LIBDIR_REL= lib/${DISTNAME}
-
-PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
- TEXMATH_VERSION=${TEXMATH_VERSION} \
- TEXMATH_LIBDIR_REL=${TEXMATH_LIBDIR_REL}
-
-.if defined(NOPORTDOCS)
-PLIST_SUB+= NOPORTDOCS=""
-.else
-PLIST_SUB+= NOPORTDOCS="@comment "
-.endif
-
-.if !defined(NOPORTDOCS)
-
-PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
-.if !empty(PORT_HADDOCK:M?0)
-BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
-.endif
-BUILD_DEPENDS+= HsColour:${PORTSDIR}/print/hs-hscolour
-
-HSCOLOUR_VERSION= 1.15
-HSCOLOUR_DATADIR= ${PREFIX}/share/hscolour-${HSCOLOUR_VERSION}
-
-PORTDOCS= *
-.endif
-
-.SILENT:
-
-do-configure:
- cd ${WRKSRC} && ${GHC_CMD} --make Setup.hs -o setup -package Cabal
-.if !defined(NOPORTDATA)
- cd ${WRKSRC} && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX}
-.else
- cd ${WRKSRC} && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX} \
- --datadir='' --datasubdir='' --docdir='${DOCSDIR}'
-.endif
-
-do-build:
- cd ${WRKSRC} && ${SETUP_CMD} build \
- && ${SETUP_CMD} register --gen-script
-
-.if !defined(NOPORTDOCS)
- cd ${WRKSRC} && ${SETUP_CMD} haddock --hyperlink-source --executables \
- --hscolour-css=${HSCOLOUR_DATADIR}/hscolour.css
-.endif
-
-do-install:
- cd ${WRKSRC} && ${SETUP_CMD} install \
- && ${INSTALL_SCRIPT} register.sh ${PREFIX}/${TEXMATH_LIBDIR_REL}/register.sh
-
-post-install:
- ${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
-
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>