aboutsummaryrefslogtreecommitdiff
path: root/textproc/html-pretty
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/html-pretty')
-rw-r--r--textproc/html-pretty/Makefile16
-rw-r--r--textproc/html-pretty/files/patch-Makefile.in10
2 files changed, 13 insertions, 13 deletions
diff --git a/textproc/html-pretty/Makefile b/textproc/html-pretty/Makefile
index 41e51044abb7..d9923d5e72df 100644
--- a/textproc/html-pretty/Makefile
+++ b/textproc/html-pretty/Makefile
@@ -18,17 +18,17 @@ GNU_CONFIGURE= yes
PORTDOCS= *
-DOCFILES= AUTHORS BUGS COPYING ChangeLog NEWS README THANKS
+OPTIONS_DEFINE= DOCS
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}/html
- ${INSTALL_DATA} ${WRKSRC}/*.html \
- ${STAGEDIR}${DOCSDIR}/html
- ${INSTALL_DATA} ${WRKSRC}/Docs/*.html \
+ ${INSTALL_DATA} ${WRKSRC}/*.html ${WRKSRC}/Docs/*.html \
${STAGEDIR}${DOCSDIR}/html
- for docfile in ${DOCFILES}; do \
- ${INSTALL_DATA} ${WRKSRC}/$$docfile ${STAGEDIR}${DOCSDIR}/; \
- done
+.for f in AUTHORS BUGS ChangeLog NEWS README THANKS
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
+.endfor
.include <bsd.port.mk>
diff --git a/textproc/html-pretty/files/patch-Makefile.in b/textproc/html-pretty/files/patch-Makefile.in
index 5841c228cbf7..ce7cd1770c13 100644
--- a/textproc/html-pretty/files/patch-Makefile.in
+++ b/textproc/html-pretty/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- ./Makefile.in.orig 2001-08-25 21:56:14.000000000 +0000
-+++ ./Makefile.in 2014-01-28 15:44:55.000000000 +0000
+--- Makefile.in.orig 2001-08-25 21:56:14 UTC
++++ Makefile.in
@@ -34,7 +34,7 @@
### install install htmlpty in system directories
### install-exe install only htmlpty executable
@@ -45,7 +45,7 @@
MANDIR = $(prefix)/man
MANEXT = 1
-@@ -217,7 +217,7 @@
+@@ -217,7 +217,7 @@ INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
INSTALL_DATA = @INSTALL_DATA@
@@ -54,7 +54,7 @@
LIBS = @LIBS@
VPATH = @srcdir@
-@@ -743,32 +743,22 @@
+@@ -743,32 +743,22 @@ htmlpty.zoo: htmlpty.tar
$(ZOO) v htmlpty-$(VERSION).zoo >htmlpty-$(VERSION).zoo-lst
$(LN) htmlpty-$(VERSION).zoo htmlpty.zoo
@@ -94,7 +94,7 @@
install-ftp: htmlpty.tar htmlpty.zip htmlpty.zoo
$(TAR) tvf htmlpty-$(VERSION).tar >$(FTPDIR)/htmlpty-$(VERSION).tar-lst
-@@ -827,14 +817,14 @@
+@@ -827,14 +817,14 @@ table.o: table.c builtin.h default.h $(H
test-version:
@echo "Version number is ""'"$(VERSION)"'"