aboutsummaryrefslogtreecommitdiff
path: root/textproc/html/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/html/Makefile')
-rw-r--r--textproc/html/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/textproc/html/Makefile b/textproc/html/Makefile
index caad0875d844..64ec012867dc 100644
--- a/textproc/html/Makefile
+++ b/textproc/html/Makefile
@@ -14,11 +14,15 @@ EXTRACT_ONLY= # empty
MAINTAINER= kuriyama@FreeBSD.org
+RUN_DEPENDS= ${MKCATALOG}:${PORTSDIR}/textproc/mkcatalog
+
NO_MTREE= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
+PLIST_SUB= DTD_NAME=${PORTNAME} MKCATALOG=${MKCATALOG}
INSTDIR= ${PREFIX}/share/sgml/html
+MKCATALOG= ${PREFIX}/sbin/mkcatalog
pre-install:
@[ -d ${INSTDIR} ] || ${MKDIR} ${INSTDIR}
@@ -28,4 +32,7 @@ do-install:
@${CHMOD} ${SHAREMODE} `find ${INSTDIR} -type f`
@${CHOWN} -R ${SHAREOWN}.${SHAREGRP} ${INSTDIR}
+post-install:
+ @${MKCATALOG} -q install ${PORTNAME}
+
.include <bsd.port.mk>