aboutsummaryrefslogtreecommitdiff
path: root/textproc/iiimf-client-lib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/iiimf-client-lib/Makefile')
-rw-r--r--textproc/iiimf-client-lib/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/textproc/iiimf-client-lib/Makefile b/textproc/iiimf-client-lib/Makefile
index 035f31a02d40..35ac2ce63732 100644
--- a/textproc/iiimf-client-lib/Makefile
+++ b/textproc/iiimf-client-lib/Makefile
@@ -26,6 +26,7 @@ USE_GMAKE= yes
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
HAS_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_FLAGS}" LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --prefix=${PREFIX} \
--includedir=${PREFIX}/include/iiimf
DIRS= lib/EIMIL lib/iiimcf
@@ -42,7 +43,7 @@ post-patch:
do-configure:
.for DIR in ${DIRS}
- cd ${WRKSRC}/${DIR} && ${SH} configure ${CONFIGURE_ARGS}
+ cd ${WRKSRC}/${DIR} && ${SETENV} ${CONFIGURE_ENV} ${SH} configure ${CONFIGURE_ARGS}
.endfor
do-build: