aboutsummaryrefslogtreecommitdiff
path: root/textproc/iso8879/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/iso8879/Makefile')
-rw-r--r--textproc/iso8879/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/textproc/iso8879/Makefile b/textproc/iso8879/Makefile
index e2377434f0d7..7c85ce196266 100644
--- a/textproc/iso8879/Makefile
+++ b/textproc/iso8879/Makefile
@@ -7,6 +7,7 @@
PORTNAME= iso8879
PORTVERSION= 1986
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= kuriyama
@@ -17,15 +18,17 @@ MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Character entity sets from ISO 8879:1986 (SGML)
BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-RUN_DEPENDS= ${MKCATALOG}:${PORTSDIR}/textproc/mkcatalog
+RUN_DEPENDS= ${XMLCATMGR}:${PORTSDIR}/textproc/xmlcatmgr
EXTRACT_ONLY= # empty
NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST_SUB= DTD_NAME=${PORTNAME} MKCATALOG=${MKCATALOG}
+PLIST_SUB= DTD_NAME=${PORTNAME} XMLCATMGR=${XMLCATMGR}
+PLIST_SUB+= CATALOG_PORTS_SGML=${CATALOG_PORTS_SGML}
INSTDIR= ${PREFIX}/share/sgml/iso8879
-MKCATALOG= ${PREFIX}/sbin/mkcatalog
+XMLCATMGR= ${LOCALBASE}/bin/xmlcatmgr
+CATALOG_PORTS_SGML= ${PREFIX}/share/sgml/catalog.ports
pre-install:
@[ -d ${INSTDIR} ] || ${MKDIR} ${INSTDIR}
@@ -37,6 +40,6 @@ do-install:
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${INSTDIR}
post-install:
- @${MKCATALOG} -q install ${PORTNAME}
+ @${XMLCATMGR} -sc ${CATALOG_PORTS_SGML} add CATALOG ${PORTNAME}/catalog
.include <bsd.port.mk>