aboutsummaryrefslogtreecommitdiff
path: root/textproc/jalingo
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/jalingo')
-rw-r--r--textproc/jalingo/Makefile46
-rw-r--r--textproc/jalingo/distinfo3
-rw-r--r--textproc/jalingo/files/jalingo.in4
-rw-r--r--textproc/jalingo/pkg-descr10
-rw-r--r--textproc/jalingo/pkg-plist4
5 files changed, 67 insertions, 0 deletions
diff --git a/textproc/jalingo/Makefile b/textproc/jalingo/Makefile
new file mode 100644
index 000000000000..d9f71a46c886
--- /dev/null
+++ b/textproc/jalingo/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: jalingo
+# Date created: 2007-03-17
+# Whom: Nicola Vitale <nivit@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jalingo
+PORTVERSION= 0.6.0
+#PORTREVISION= 0
+CATEGORIES= textproc java
+MASTER_SITES= SFE
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+EXTRACT_SUFX= .7z
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= A free OS indipendent dictionary application
+
+EXTRACT_DEPENDS= 7z:${PORTSDIR}/archivers/p7zip
+
+USE_ANT= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+
+ALL_TARGET= dist
+
+P7ZIP_CMD= ${LOCALBASE}/bin/7z
+P7ZIP_ARGS= x -o${WRKDIR}
+
+SUB_FILES= ${PORTNAME}
+SUB_LIST= JALINGOJAR=${JALINGOJAR}
+PLIST_SUB= JALINGOJAR=${JALINGOJAR}
+
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+
+JALINGOJAR= ${PORTNAME}.jar
+
+do-extract:
+ @${MKDIR} ${WRKDIR} && ${P7ZIP_CMD} ${P7ZIP_ARGS} ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/dist/${JALINGOJAR} ${DATADIR}/${JALINGOJAR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/textproc/jalingo/distinfo b/textproc/jalingo/distinfo
new file mode 100644
index 000000000000..f382239cc759
--- /dev/null
+++ b/textproc/jalingo/distinfo
@@ -0,0 +1,3 @@
+MD5 (jalingo-0.6.0-src.7z) = ef0142d43353bd0b4b6ba56210c07670
+SHA256 (jalingo-0.6.0-src.7z) = 58f02c271ed18fe4d89cb53a9f92df989dff312effdfb0287142c53b9ec35a8f
+SIZE (jalingo-0.6.0-src.7z) = 1255680
diff --git a/textproc/jalingo/files/jalingo.in b/textproc/jalingo/files/jalingo.in
new file mode 100644
index 000000000000..bbbc7e03f34b
--- /dev/null
+++ b/textproc/jalingo/files/jalingo.in
@@ -0,0 +1,4 @@
+#!/bin/sh
+# $FreeBSD$
+JAVA_VERSION="%%JAVA_VERSION%%" \
+exec "%%LOCALBASE%%/bin/java" -jar %%DATADIR%%/%%JALINGOJAR%% "$@"
diff --git a/textproc/jalingo/pkg-descr b/textproc/jalingo/pkg-descr
new file mode 100644
index 000000000000..4196e6f0a135
--- /dev/null
+++ b/textproc/jalingo/pkg-descr
@@ -0,0 +1,10 @@
+JaLingo is a free OS independent dictionary application.
+
+It understands 4 dictionary formats:
+
+ * DSL
+ * Mova
+ * PtkDict/phpMyLingvo MySQL dumps
+ * Sdictionary (249)
+
+WWW: http://jalingo.sourceforge.net/
diff --git a/textproc/jalingo/pkg-plist b/textproc/jalingo/pkg-plist
new file mode 100644
index 000000000000..010457e7d71f
--- /dev/null
+++ b/textproc/jalingo/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+bin/jalingo
+%%DATADIR%%/%%JALINGOJAR%%
+@dirrm %%DATADIR%%