aboutsummaryrefslogtreecommitdiff
path: root/textproc/libcroco/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/libcroco/Makefile')
-rw-r--r--textproc/libcroco/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/textproc/libcroco/Makefile b/textproc/libcroco/Makefile
index 42e3e679c4b9..fa0c38a119fa 100644
--- a/textproc/libcroco/Makefile
+++ b/textproc/libcroco/Makefile
@@ -1,26 +1,29 @@
-# New ports collection makefile for: libcroco
-# Date created: 08 July 2003
-# Whom: Adam Weinberger <adamw@FreeBSD.org>
-#
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= libcroco
-PORTVERSION= 0.6.2
-PORTREVISION= 1
+PORTVERSION= 0.6.8
CATEGORIES= textproc gnome
MASTER_SITES= GNOME
MAINTAINER= gnome@FreeBSD.org
COMMENT= CSS2 parsing library
-USE_BZIP2= yes
+USE_XZ= yes
USE_GETTEXT= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
USE_GNOME= gnomehack glib20 libxml2 ltverhack
+USE_PKGCONFIG= build
+CONFIGURE_ARGS= --disable-gtk-doc-html
PLIST_SUB= VERSION="0.6"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 900035
+CONFIGURE_ARGS+=--disable-Bsymbolic
+.endif
+
+.include <bsd.port.post.mk>