aboutsummaryrefslogtreecommitdiff
path: root/textproc/libflate
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/libflate')
-rw-r--r--textproc/libflate/Makefile21
-rw-r--r--textproc/libflate/distinfo2
-rw-r--r--textproc/libflate/pkg-descr9
3 files changed, 32 insertions, 0 deletions
diff --git a/textproc/libflate/Makefile b/textproc/libflate/Makefile
new file mode 100644
index 000000000000..627578fc381a
--- /dev/null
+++ b/textproc/libflate/Makefile
@@ -0,0 +1,21 @@
+# Created by: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+# $FreeBSD$
+
+PORTNAME= libflate
+PORTVERSION= 2.0
+CATEGORIES= textproc devel
+MASTER_SITES= http://flate.dead-inside.org/
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= Template library used to deal with html code in CGI applications
+
+PLIST_FILES= lib/${PORTNAME}.a \
+ bin/checktpl
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/checktpl ${PREFIX}/bin/
+ @${INSTALL_LIB} ${WRKSRC}/${PORTNAME}.a ${PREFIX}/lib/
+
+.include <bsd.port.post.mk>
diff --git a/textproc/libflate/distinfo b/textproc/libflate/distinfo
new file mode 100644
index 000000000000..51b88d95057a
--- /dev/null
+++ b/textproc/libflate/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libflate-2.0.tar.gz) = fec6252876cea88acea08fa2ded632c681238ccd15138f0a4399b103e78c5bc8
+SIZE (libflate-2.0.tar.gz) = 22376
diff --git a/textproc/libflate/pkg-descr b/textproc/libflate/pkg-descr
new file mode 100644
index 000000000000..fe60ebd5583c
--- /dev/null
+++ b/textproc/libflate/pkg-descr
@@ -0,0 +1,9 @@
+Flate is a template library used to deal with html code in CGI applications.
+The library includes C and Perl support. All html code is put in an external
+file (the template) and printed using the library functions: variables, zones
+(parts to be displayed or not) and tables (parts to be displayed 0 to n times).
+Using this method you don't need to modify/recompile your application when
+modifying html code, printing order doesn't matter in your CGI code, and your
+CGI code is much cleaner.
+
+WWW: http://flate.dead-inside.org/