aboutsummaryrefslogtreecommitdiff
path: root/textproc/libmrss/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/libmrss/Makefile')
-rw-r--r--textproc/libmrss/Makefile19
1 files changed, 18 insertions, 1 deletions
diff --git a/textproc/libmrss/Makefile b/textproc/libmrss/Makefile
index 8bd3510399af..61744038e7c5 100644
--- a/textproc/libmrss/Makefile
+++ b/textproc/libmrss/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libmrss
PORTVERSION= 0.18.0
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://www5.autistici.org/bakunin/libmrss/ GENTOO/distfiles
@@ -17,6 +18,8 @@ BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl \
nxml.18:${PORTSDIR}/textproc/libnxml
+OPTIONS= PHPMRSS "support to PHP" on
+
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -28,4 +31,18 @@ WANT_GNOME= yes
pre-patch:
${gnomehack_PRE_PATCH}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PHPMRSS)
+USE_PHP= yes
+USE_AUTOTOOLS+= autoconf:259:env
+BUILD_DEPENDS+= phpize:${PHP_PORT}
+post-install:
+ @(cd ${WRKSRC}/phpmrss; ${SETENV} ${SCRIPTS_ENV} ${LOCALBASE}/bin/phpize)
+ @(cd ${WRKSRC}/phpmrss; ./configure; ${MAKE} install)
+PLIST_SUB+= PHPMRSS=""
+.else
+PLIST_SUB+= PHPMRSS="@comment "
+.endif
+
+.include <bsd.port.post.mk>