aboutsummaryrefslogtreecommitdiff
path: root/textproc/libtext-charwidth-perl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/libtext-charwidth-perl/Makefile')
-rw-r--r--textproc/libtext-charwidth-perl/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/textproc/libtext-charwidth-perl/Makefile b/textproc/libtext-charwidth-perl/Makefile
new file mode 100644
index 000000000000..c7ea14418720
--- /dev/null
+++ b/textproc/libtext-charwidth-perl/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: libtext-charwidth-perl
+# Date created: 08 Januar 2006
+# Whom: Meno Abels <meno.abels@adviser.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libtext-charwidth-perl
+PORTVERSION= 0.04
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_DEBIAN}
+MASTER_SITE_SUBDIR= pool/main/libt/libtext-charwidth-perl
+DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
+
+MAINTAINER= Meno.Abels@Adviser.com
+COMMENT= Documentation gettext tools
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+PERL_CONFIGURE= yes
+
+MAN3= Text::CharWidth.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= perl 5.8 or newer required. Install lang/perl5.8 and try again
+.endif
+
+post-extract:
+ @${MV} ${WRKSRC}.orig ${WRKSRC}
+
+.include <bsd.port.post.mk>