aboutsummaryrefslogtreecommitdiff
path: root/textproc/libxml++26/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/libxml++26/Makefile')
-rw-r--r--textproc/libxml++26/Makefile28
1 files changed, 16 insertions, 12 deletions
diff --git a/textproc/libxml++26/Makefile b/textproc/libxml++26/Makefile
index a2fee3b6a88c..2ac9ee98bbbd 100644
--- a/textproc/libxml++26/Makefile
+++ b/textproc/libxml++26/Makefile
@@ -4,29 +4,34 @@
# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/textproc/libxml++26/Makefile,v 1.35 2009/03/17 14:57:40 kwm Exp $
+# $MCom: ports/textproc/libxml++26/Makefile,v 1.37 2010/04/03 16:02:01 avl Exp $
#
PORTNAME= libxml++
-PORTVERSION= 2.26.1
+PORTVERSION= 2.30.0
+PORTREVISION?= 0
CATEGORIES= textproc
MASTER_SITES= GNOME
MAINTAINER= bland@FreeBSD.org
COMMENT= XML API for C++
-LIB_DEPENDS= glibmm-2.4.1:${PORTSDIR}/devel/glibmm
-BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
+USE_BZIP2= yes
+
+PLIST_SUB= VERSION="2.6" API_VERSION="2.6"
+
+.if !defined(REFERENCE_PORT)
LATEST_LINK= libxml++26
+LIB_DEPENDS= glibmm-2.4.1:${PORTSDIR}/devel/glibmm
+BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
+
USE_GMAKE= yes
-USE_BZIP2= yes
USE_GNOME= gnomehack libxml2 pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-
-PLIST_SUB= VERSION="2.6" API_VERSION="2.6" DOC_VERSION=${PORTVERSION:R}
+CONFIGURE_ARGS= --enable-static --disable-documentation
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS =/s/examples//' \
@@ -34,11 +39,10 @@ post-patch:
@${REINPLACE_CMD} -e '/^gentoo_ltmain_version=/s/`.*`/$$gentoo_lt_version/' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e '/^library_configdir =/s/libdir/includedir/' \
- ${WRKSRC}/libxml++/Makefile.in
+ ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '/^Cflags:/s/libdir/includedir/' \
- ${WRKSRC}/libxml++-2.6.pc.in
-.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -E '/^SUBDIRS = /s/(docs|examples)//g' ${WRKSRC}/Makefile.in
-.endif
+ ${WRKSRC}/libxml++-2.6.pc.in
.include <bsd.port.mk>
+
+.endif \ No newline at end of file