aboutsummaryrefslogtreecommitdiff
path: root/textproc/libxslt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/libxslt/Makefile')
-rw-r--r--textproc/libxslt/Makefile29
1 files changed, 10 insertions, 19 deletions
diff --git a/textproc/libxslt/Makefile b/textproc/libxslt/Makefile
index e009accdd2f8..7c05a20b25a9 100644
--- a/textproc/libxslt/Makefile
+++ b/textproc/libxslt/Makefile
@@ -7,7 +7,8 @@
PORTNAME= libxslt
PORTVERSION= 1.1.8
-CATEGORIES= textproc gnome
+PORTREVISION= 1
+CATEGORIES?= textproc gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.1
DIST_SUBDIR= gnome2
@@ -19,25 +20,20 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
-USE_GNOME= gnomehack gnometarget libxml2
+USE_GNOME?= gnomehack lthack gnometarget libxml2
USE_REINPLACE= yes
-CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
+CONFIGURE_ARGS?= --with-html-dir=${PREFIX}/share/doc \
+ --without-python
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+.if defined(MASTERDIR)
+_SLAVE_PORT= yes
+.else
MAN3= libexslt.3 libxslt.3
MAN1= xsltproc.1
OPTIONS= MEM_DEBUG "Enable memory debugging" off
-
-.if !defined(WITHOUT_PYTHON)
-USE_PYTHON= yes
-PLIST_SUB+= PYTHON:=""
-CONFIGURE_ARGS+= --with-python=${LOCALBASE}
-.else
-CONFIGURE_ARGS+= --without-python
-PLIST_SUB+= PYTHON:="@comment "
-PKGNAMESUFFIX= -nopython
.endif
.include <bsd.port.pre.mk>
@@ -46,6 +42,7 @@ PKGNAMESUFFIX= -nopython
CONFIGURE_ARGS+= --with-mem-debug
.endif
+.if !defined(_SLAVE_PORT)
.if exists(${LOCALBASE}/lib/libgcrypt.so)
WITH_GCRYPT= yes
.endif
@@ -58,19 +55,13 @@ pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "Libxslt has the following additional tunables:"
@${ECHO_MSG} ""
- @${ECHO_MSG} " WITHOUT_PYTHON=yes Turns off python support"
@${ECHO_MSG} " WITH_GCRYPT=yes Turns on libgcrypt support"
@${ECHO_MSG} ""
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|[$$](bindir)/xsltproc|../xsltproc/xsltproc|g ; \
s|[$$](bindir)/xmllint|../xmllint/xmllint|g' \
${WRKSRC}/doc/Makefile.in
-.if !defined(WITHOUT_PYTHON)
-post-install:
- @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -l ${PYTHON_SITELIBDIR}
- @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py -l ${PYTHON_SITELIBDIR}
-.endif
-
.include <bsd.port.post.mk>