aboutsummaryrefslogtreecommitdiff
path: root/textproc/man2html/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/man2html/Makefile')
-rw-r--r--textproc/man2html/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/textproc/man2html/Makefile b/textproc/man2html/Makefile
new file mode 100644
index 000000000000..617e8970a804
--- /dev/null
+++ b/textproc/man2html/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: man2html
+# Version required: 3.0.1
+# Date created: 29 August 1998
+# Whom: Dima Sivachenko <demon@gpad.ac.ru>
+#
+# $Id$
+#
+
+DISTNAME= man2html3.0.1
+PKGNAME= man2html-3.0.1
+CATEGORIES= textproc
+MASTER_SITES= ftp://ftp.gpad.ac.ru/pub/FreeBSD/distfiles/
+
+MAINTAINER= demon@gpad.ac.ru
+
+USE_PERL5= yes
+NO_BUILD= yes
+CGIDIR= ${PREFIX}/www/cgi-bin
+
+MAN1= man2html.1
+
+post-patch:
+
+ if [ -f ${CGIDIR} ] ; then \
+ ${MV} ${WRKSRC}/man.cgi ${WRKSRC}/man.cgi.pre_sed ; \
+ ${CAT} ${WRKSRC}/man.cgi.pre_sed | \
+ ${GREP} -Ev -e "/opt/|/openwin/" \
+ > ${WRKSRC}/man.cgi ; \
+ fi
+
+do-install:
+
+ cd ${WRKSRC} && \
+ ${PERL5} ${WRKSRC}/install.me -batch -binpath ${PREFIX}/bin \
+ -manpath ${PREFIX}/man -libpath ${PREFIX}/lib \
+ -perlpath ${PERL5}
+ if [ -f ${CGIDIR} ] ; then \
+ ${INSTALL_PROGRAM} ${WRKSRC}/man.cgi ${CGIDIR} ; \
+ fi
+
+.include <bsd.port.mk>