aboutsummaryrefslogtreecommitdiff
path: root/textproc/no-hunspell/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/no-hunspell/Makefile')
-rw-r--r--textproc/no-hunspell/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/textproc/no-hunspell/Makefile b/textproc/no-hunspell/Makefile
index abb6d0a09945..bbb5ca072d24 100644
--- a/textproc/no-hunspell/Makefile
+++ b/textproc/no-hunspell/Makefile
@@ -5,10 +5,12 @@
# $FreeBSD$
#
-PORTNAME= no-hunspell
+PORTNAME= hunspell
PORTVERSION= 2.0.10
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= https://alioth.debian.org/frs/download.php/2357/
+PKGNAMEPREFIX= no-
DISTNAME= no_NO-pack2-${PORTVERSION}
MAINTAINER= office@FreeBSD.org
@@ -17,18 +19,19 @@ COMMENT= Norwegian (Nynorsk and Bokmaal) hunspell dictionaries
USE_ZIP= yes
NO_BUILD= yes
-PLIST_FILES= share/hunspell/nb_NO.aff \
- share/hunspell/nb_NO.dic \
- share/hunspell/nn_NO.aff \
- share/hunspell/nn_NO.dic
-PLIST_DIRS= share/hunspell
+PLIST_FILES= %%DATADIR%%/nb_NO.aff \
+ %%DATADIR%%/nb_NO.dic \
+ %%DATADIR%%/nn_NO.aff \
+ %%DATADIR%%/nn_NO.dic
+PLIST_DIRSTRY= %%DATADIR%%
post-extract:
@${EXTRACT_CMD} ${WRKDIR}/nb_NO.zip -d ${WRKSRC}
@${EXTRACT_CMD} ${WRKDIR}/nn_NO.zip -d ${WRKSRC}
do-install:
- @${MKDIR} ${PREFIX}/share/hunspell
- @${INSTALL_DATA} ${WRKSRC}/n?_NO.* ${PREFIX}/share/hunspell
+ ${MKDIR} ${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/nb_NO.aff ${WRKSRC}/nb_NO.dic \
+ ${WRKSRC}/nn_NO.aff ${WRKSRC}/nn_NO.dic ${DATADIR}/
.include <bsd.port.mk>