aboutsummaryrefslogtreecommitdiff
path: root/textproc/ocaml-pxp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/ocaml-pxp/Makefile')
-rw-r--r--textproc/ocaml-pxp/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/textproc/ocaml-pxp/Makefile b/textproc/ocaml-pxp/Makefile
index 3d0972286da4..c27e5d2658ea 100644
--- a/textproc/ocaml-pxp/Makefile
+++ b/textproc/ocaml-pxp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pxp
PORTVERSION= 1.1.95
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://www.ocaml-programming.de/packages/
PKGNAMEPREFIX= ocaml-
@@ -20,6 +21,11 @@ BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
${LOCALBASE}/lib/ocaml/site-lib/netstring/netstring.a:${PORTSDIR}/www/ocaml-net
RUN_DEPENDS= ${LOCALBASE}/lib/ocaml/site-lib/netstring/netstring.a:${PORTSDIR}/www/ocaml-net
+.if !defined(WITHOUT_ULEX)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/ocaml/site-lib/ulex/ulexing.a:${PORTSDIR}/devel/ocaml-ulex
+RUN_DEPENDS+= ${LOCALBASE}/lib/ocaml/site-lib/ulex/ulexing.a:${PORTSDIR}/devel/ocaml-ulex
+.endif
+
USE_GMAKE= yes
HAS_CONFIGURE= yes
@@ -33,4 +39,10 @@ ALL_TARGET= all opt
post-extract:
${FIND} ${WRKSRC} -name "Makefile*" | ${XARGS} ${REINPLACE_CMD} -e 's/PACKAGES/PXP_PACKAGES/'
+post-install:
+ @${FIND} ${PREFIX}/lib/ocaml/site-lib/pxp* -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/lib/ocaml/site-lib/ -type d -name 'pxp*' | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+
.include <bsd.port.mk>