aboutsummaryrefslogtreecommitdiff
path: root/textproc/ocaml-text
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/ocaml-text')
-rw-r--r--textproc/ocaml-text/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/textproc/ocaml-text/Makefile b/textproc/ocaml-text/Makefile
index 6438bbb73fa6..6f406c977c3d 100644
--- a/textproc/ocaml-text/Makefile
+++ b/textproc/ocaml-text/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: ocaml-text
-# Date created: April 18, 2011
-# Whom: Jaap Boender <jaapb@kerguelen.org>
-#
+# Created by: Jaap Boender <jaapb@kerguelen.org>
# $FreeBSD$
PORTNAME= text
@@ -25,18 +22,20 @@ USE_OCAML_FINDLIB= yes
USE_OCAML_LDCONFIG= yes
USE_OCAMLFIND_PLIST= yes
-OPTIONS= PCRE "Compile with PCRE support" ON
+OPTIONS_DEFINE= PCRE
+OPTIONS_DEFAULT= PCRE
SA_DIR= ${LOCALBASE}/${OCAML_SITELIBDIR}
.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_PCRE)
-CONFIGURE_ARGS+= --disable-pcre
-.else
+.if ${PORT_OPTIONS:MPCRE}
CONFIGURE_ARGS+= --enable-pcre
BUILD_DEPENDS+= ${SA_DIR}/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre
RUN_DEPENDS+= ${SA_DIR}/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre
+.else
+CONFIGURE_ARGS+= --disable-pcre
.endif
post-extract: