aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-CSS-SAC/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-CSS-SAC/Makefile')
-rw-r--r--textproc/p5-CSS-SAC/Makefile21
1 files changed, 2 insertions, 19 deletions
diff --git a/textproc/p5-CSS-SAC/Makefile b/textproc/p5-CSS-SAC/Makefile
index 37c8bc3349a9..48c9ad396599 100644
--- a/textproc/p5-CSS-SAC/Makefile
+++ b/textproc/p5-CSS-SAC/Makefile
@@ -11,30 +11,13 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= SAC CSS (Simple API for CSS) parser
-RUN_DEPENDS= p5-Class-ArrayObjects>=0.04:${PORTSDIR}/devel/p5-Class-ArrayObjects
-BUILD_DEPENDS:= ${RUN_DEPENDS}
+BUILD_DEPENDS= p5-Class-ArrayObjects>=0.04:${PORTSDIR}/devel/p5-Class-ArrayObjects
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
-MAN3= CSS::SAC.3 CSS::SAC::Condition.3 \
- CSS::SAC::Condition::Attribute.3 \
- CSS::SAC::Condition::Combinator.3 \
- CSS::SAC::Condition::Content.3 CSS::SAC::Condition::Lang.3 \
- CSS::SAC::Condition::Negative.3 \
- CSS::SAC::Condition::Positional.3 CSS::SAC::ConditionFactory.3 \
- CSS::SAC::LexicalUnit.3 CSS::SAC::Selector.3 \
- CSS::SAC::Selector::CharacterData.3 \
- CSS::SAC::Selector::Conditional.3 \
- CSS::SAC::Selector::Descendant.3 CSS::SAC::Selector::Element.3 \
- CSS::SAC::Selector::Negative.3 \
- CSS::SAC::Selector::ProcessingInstruction.3 \
- CSS::SAC::Selector::Sibling.3 CSS::SAC::Selector::Simple.3 \
- CSS::SAC::SelectorFactory.3 CSS::SAC::SelectorList.3 \
- CSS::SAC::TestWriter.3 CSS::SAC::Writer.3
-
# Bareword "_out_" not allowed while "strict subs"
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e "s,_out_,'_out_',g" ${WRKSRC}/lib/CSS/SAC/TestWriter.pm
@${FIND} ${WRKSRC} -name "*.bak" -delete