aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-HTML-EscapeEvil/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-HTML-EscapeEvil/Makefile')
-rw-r--r--textproc/p5-HTML-EscapeEvil/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/textproc/p5-HTML-EscapeEvil/Makefile b/textproc/p5-HTML-EscapeEvil/Makefile
new file mode 100644
index 000000000000..d920a6b9f7c6
--- /dev/null
+++ b/textproc/p5-HTML-EscapeEvil/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: textproc/p5-HTML-EscapeEvil
+# Date created: 13 February 2006
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-EscapeEvil
+PORTVERSION= 0.03
+CATEGORIES= textproc perl5 www
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= HTML::EscapeEvil - escape evil HTML tags
+
+BUILD_DEPENDS= ${SITE_PERL}/HTML/Element.pm:${PORTSDIR}/www/p5-HTML-Tree \
+ ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/${PERL_ARCH}/HTML/Filter.pm:${PORTSDIR}/www/p5-HTML-Parser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::EscapeEvil.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>