aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-PDF-WebKit
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-PDF-WebKit')
-rw-r--r--textproc/p5-PDF-WebKit/Makefile27
-rw-r--r--textproc/p5-PDF-WebKit/distinfo2
-rw-r--r--textproc/p5-PDF-WebKit/pkg-descr8
-rw-r--r--textproc/p5-PDF-WebKit/pkg-plist4
4 files changed, 41 insertions, 0 deletions
diff --git a/textproc/p5-PDF-WebKit/Makefile b/textproc/p5-PDF-WebKit/Makefile
new file mode 100644
index 000000000000..ad40751051ca
--- /dev/null
+++ b/textproc/p5-PDF-WebKit/Makefile
@@ -0,0 +1,27 @@
+# Created by: Gea-Suan Lin <gslin@gslin.org>
+# $FreeBSD$
+
+PORTNAME= PDF-WebKit
+PORTVERSION= 0.92
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Use WebKit to Generate PDFs from HTML
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-IPC-Run>=0:${PORTSDIR}/devel/p5-IPC-Run \
+ p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-XML-LibXML>=1.62:${PORTSDIR}/textproc/p5-XML-LibXML
+RUN_DEPENDS:= ${BUILD_DEPENDS} \
+ wkhtmltopdf:${PORTSDIR}/converters/wkhtmltopdf
+TEST_DEPENDS= p5-Test-Spec:${PORTSDIR}/devel/p5-Test-Spec
+
+USE_PERL5= configure
+USES= perl5
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-PDF-WebKit/distinfo b/textproc/p5-PDF-WebKit/distinfo
new file mode 100644
index 000000000000..1fb98db8dc89
--- /dev/null
+++ b/textproc/p5-PDF-WebKit/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PDF-WebKit-0.92.tar.gz) = 22ec2ae4129d6145943e000cb97ba152d6c8ff71d2010a492813bbd9d7267c74
+SIZE (PDF-WebKit-0.92.tar.gz) = 24043
diff --git a/textproc/p5-PDF-WebKit/pkg-descr b/textproc/p5-PDF-WebKit/pkg-descr
new file mode 100644
index 000000000000..2bdd5b622769
--- /dev/null
+++ b/textproc/p5-PDF-WebKit/pkg-descr
@@ -0,0 +1,8 @@
+PDF::WebKit uses wkhtmltopdf to convert HTML documents into PDFs. It
+is a port of the elegant PDFKit Ruby library.
+
+wkhtmltopdf generates beautiful PDFs by leveraging the rendering power
+of Qt's WebKit browser engine (used by both Apple Safari and Google
+Chrome browsers).
+
+WWW: https://metacpan.org/release/PDF-WebKit
diff --git a/textproc/p5-PDF-WebKit/pkg-plist b/textproc/p5-PDF-WebKit/pkg-plist
new file mode 100644
index 000000000000..c88dfba74b38
--- /dev/null
+++ b/textproc/p5-PDF-WebKit/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/PDF/WebKit.pm
+%%SITE_PERL%%/PDF/WebKit/Configuration.pm
+%%SITE_PERL%%/PDF/WebKit/Source.pm
+%%PERL5_MAN3%%/PDF::WebKit.3.gz