aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Perl-MinimumVersion/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-Perl-MinimumVersion/Makefile')
-rw-r--r--textproc/p5-Perl-MinimumVersion/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/textproc/p5-Perl-MinimumVersion/Makefile b/textproc/p5-Perl-MinimumVersion/Makefile
index 450c2d8c4b32..5713092124d7 100644
--- a/textproc/p5-Perl-MinimumVersion/Makefile
+++ b/textproc/p5-Perl-MinimumVersion/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= p5-File-Find-Rule>=0.32:${PORTSDIR}/devel/p5-File-Find-Rule \
p5-Perl-Critic>=1.10.4:${PORTSDIR}/textproc/p5-Perl-Critic \
p5-Params-Util>=0.25:${PORTSDIR}/devel/p5-Params-Util \
p5-version>=0.76:${PORTSDIR}/devel/p5-version
-BUILD_DEPENDS:= ${RUN_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
@@ -30,4 +30,8 @@ MAN3= Perl::MinimumVersion.3
post-patch:
@${PERL} -pi -e '$$_="" if m/Test::/' ${WRKSRC}/Makefile.PL
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 501001
+RUN_DEPENDS+= p5-Scalar-List-Utils>=1.20:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.endif
+.include <bsd.port.post.mk>