aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Petal-Mail/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-Petal-Mail/Makefile')
-rw-r--r--textproc/p5-Petal-Mail/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/textproc/p5-Petal-Mail/Makefile b/textproc/p5-Petal-Mail/Makefile
new file mode 100644
index 000000000000..d4da873fa550
--- /dev/null
+++ b/textproc/p5-Petal-Mail/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Petal-Mail
+# Date created: 26 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Petal-Mail
+PORTVERSION= 0.31
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/B/BP/BPOSTLE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Format text e-mail using Petal
+
+BUILD_DEPENDS= ${SITE_PERL}/Petal.pm:${PORTSDIR}/textproc/p5-Petal \
+ ${SITE_PERL}/${PERL_ARCH}/Encode.pm:${PORTSDIR}/devel/p5-Encode
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Petal::Mail.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+IGNORE= requires at least Perl 5.7.3 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>