aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Pod-Autopod/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-Pod-Autopod/Makefile')
-rw-r--r--textproc/p5-Pod-Autopod/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/textproc/p5-Pod-Autopod/Makefile b/textproc/p5-Pod-Autopod/Makefile
new file mode 100644
index 000000000000..41af8e2541ce
--- /dev/null
+++ b/textproc/p5-Pod-Autopod/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Pod-Autopod
+# Date created: 31 Oct, 2009
+# Whom: Wen Heping<wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Pod-Autopod
+PORTVERSION= 1.07
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Generates pod documentation by analysing perl modules
+
+BUILD_DEPENDS= p5-Pod-Abstract>=0.19:${PORTSDIR}/textproc/p5-Pod-Abstract
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= autopod.1
+MAN3= Pod::Autopod.3
+
+.include <bsd.port.mk>