aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Pod-DocBook/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-Pod-DocBook/Makefile')
-rw-r--r--textproc/p5-Pod-DocBook/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/textproc/p5-Pod-DocBook/Makefile b/textproc/p5-Pod-DocBook/Makefile
new file mode 100644
index 000000000000..17b07ca7e8b9
--- /dev/null
+++ b/textproc/p5-Pod-DocBook/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Pod-DocBook
+# Date created: 29 July 2004
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Pod-DocBook
+PORTVERSION= 1.2
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/N/NA/NANDU
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Convert Pod data to DocBook SGML
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser \
+ ${SITE_PERL}/Pod/ParseLink.pm:${PORTSDIR}/textproc/p5-podlators \
+ ${SITE_PERL}/Text/Wrap.pm:${PORTSDIR}/textproc/p5-Text-Tabs+Wrap
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= pod2docbook.1
+MAN3= Pod::DocBook.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= "Perl 5.6.1 or newer required. Install lang/perl5.8 or lang/perl5 and try again."
+.endif
+
+.include <bsd.port.post.mk>