aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Pod-Elemental/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-Pod-Elemental/Makefile')
-rw-r--r--textproc/p5-Pod-Elemental/Makefile20
1 files changed, 13 insertions, 7 deletions
diff --git a/textproc/p5-Pod-Elemental/Makefile b/textproc/p5-Pod-Elemental/Makefile
index 49eeb345c466..f1dcb5385eb8 100644
--- a/textproc/p5-Pod-Elemental/Makefile
+++ b/textproc/p5-Pod-Elemental/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Pod-Elemental
-PORTVERSION= 0.102360
+PORTVERSION= 0.102361
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,16 +14,16 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Treating a Pod documents as trees of elements
-BUILD_DEPENDS= p5-Pod-Eventual>=0:${PORTSDIR}/textproc/p5-Pod-Eventual \
- p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
- p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean \
+BUILD_DEPENDS= p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
p5-Moose-Autobox>=0.10:${PORTSDIR}/devel/p5-Moose-Autobox \
p5-MooseX-Types>=0:${PORTSDIR}/devel/p5-MooseX-Types \
+ p5-Pod-Eventual>=0:${PORTSDIR}/textproc/p5-Pod-Eventual \
p5-String-RewritePrefix>=0:${PORTSDIR}/textproc/p5-String-RewritePrefix \
p5-String-Truncate>=0:${PORTSDIR}/textproc/p5-String-Truncate \
+ p5-Sub-Exporter-ForMethods>=0:${PORTSDIR}/devel/p5-Sub-Exporter-ForMethods \
p5-Test-Differences>=0:${PORTSDIR}/devel/p5-Test-Differences \
- p5-Sub-Exporter-ForMethods>=0:${PORTSDIR}/devel/p5-Sub-Exporter-ForMethods
-RUN_DEPENDS= ${BUILD_DEPENDS}
+ p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -54,4 +54,10 @@ MAN3= Pod::Elemental.3 \
Pod::Elemental::Transformer::Pod5.3 \
Pod::Elemental::Types.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501400
+TEST_DEPENDS+= p5-Test-Simple>=0.96:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>