aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Pod-Stripper/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-Pod-Stripper/Makefile')
-rw-r--r--textproc/p5-Pod-Stripper/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/textproc/p5-Pod-Stripper/Makefile b/textproc/p5-Pod-Stripper/Makefile
index d684b7c8e74a..cca5d55dc9ce 100644
--- a/textproc/p5-Pod-Stripper/Makefile
+++ b/textproc/p5-Pod-Stripper/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Pod-Stripper
PORTVERSION= 0.22
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Pod
@@ -16,6 +16,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= Strip all pod, and output what's left
+BUILD_DEPENDS= ${SITE_PERL}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
PERL_CONFIGURE= yes
CONFIGURE_ARGS= INSTALLDIRS="site"
@@ -25,12 +28,4 @@ MAN3= Pod::Stripper.3
post-patch:
@${FIND} ${WRKSRC} -type f|${XARGS} ${PERL} -pi -e 's/\x0d(?=\x0a)//;'
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500601
-BUILD_DEPENDS+= ${SITE_PERL}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser
-RUN_DEPENDS+= ${BUILD_DEPENDS}
-
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>