aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Text-ASCIITable/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-Text-ASCIITable/Makefile')
-rw-r--r--textproc/p5-Text-ASCIITable/Makefile19
1 files changed, 7 insertions, 12 deletions
diff --git a/textproc/p5-Text-ASCIITable/Makefile b/textproc/p5-Text-ASCIITable/Makefile
index f5d2c4b24371..6f6616e70ad9 100644
--- a/textproc/p5-Text-ASCIITable/Makefile
+++ b/textproc/p5-Text-ASCIITable/Makefile
@@ -10,24 +10,19 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Create a nice formatted table using ASCII characters
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
USES= perl5
USE_PERL5= configure
-MAN3= Text::ASCIITable.3 \
- Text::ASCIITable::Wrap.3
+OPTIONS_DEFINE= EXAMPLES
-NO_STAGE= yes
-post-extract:
- @${MKDIR} ${WRKSRC}/example
- @${MV} ${WRKSRC}/ansi-example.pl ${WRKSRC}/example
- @${REINPLACE_CMD} -i '' '/ansi-example.pl/d' ${WRKSRC}/MANIFEST
+PORTEXAMPLES= ansi-example.pl
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_SCRIPT} ${WRKSRC}/example/ansi-example.pl ${EXAMPLESDIR}
- @${ECHO_MSG} "===> Example installed in ${EXAMPLESDIR}."
-.endif
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/ansi-example.pl ${STAGEDIR}${EXAMPLESDIR}
regression-test: build
cd ${WRKSRC}/ && ./Build test