aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Text-SimpleTable/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-Text-SimpleTable/Makefile')
-rw-r--r--textproc/p5-Text-SimpleTable/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/textproc/p5-Text-SimpleTable/Makefile b/textproc/p5-Text-SimpleTable/Makefile
new file mode 100644
index 000000000000..63ad013a1393
--- /dev/null
+++ b/textproc/p5-Text-SimpleTable/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Text-SimpleTable
+# Date created: 15 Nov 2005
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-SimpleTable
+PORTVERSION= 0.02
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/S/SR/SRI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Simple Eyecandy ASCII Tables
+
+PERL_MODBUILD= yes
+
+MAN3= Text::SimpleTable.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ @${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1); $$1/;' \
+ ${WRKSRC}/lib/Text/SimpleTable.pm
+.endif
+.include <bsd.port.post.mk>