aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-Feed/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-XML-Feed/Makefile')
-rw-r--r--textproc/p5-XML-Feed/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/textproc/p5-XML-Feed/Makefile b/textproc/p5-XML-Feed/Makefile
new file mode 100644
index 000000000000..415007c8a3a8
--- /dev/null
+++ b/textproc/p5-XML-Feed/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: p5-XML-Feed
+# Date created: Jul 31 2004
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Feed
+PORTVERSION= 0.02
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Perl5 modules for Syndication feed parser and auto-discovery
+
+BUILD_DEPENDS= ${SITE_PERL}/XML/RSS.pm:${PORTSDIR}/textproc/p5-XML-RSS \
+ ${SITE_PERL}/XML/Atom.pm:${PORTSDIR}/textproc/p5-XML-Atom \
+ ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
+ ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/DateTime/Format/Mail.pm:${PORTSDIR}/devel/p5-DateTime-Format-Mail \
+ ${SITE_PERL}/DateTime/Format/W3CDTF.pm:${PORTSDIR}/devel/p5-DateTime-Format-W3CDTF \
+ ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= XML::Feed.3 \
+ XML::Feed::Content.3 \
+ XML::Feed::Entry.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>