aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-Parser/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-XML-Parser/Makefile')
-rw-r--r--textproc/p5-XML-Parser/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/textproc/p5-XML-Parser/Makefile b/textproc/p5-XML-Parser/Makefile
index 5d1a51b7d9cb..83869b6ab610 100644
--- a/textproc/p5-XML-Parser/Makefile
+++ b/textproc/p5-XML-Parser/Makefile
@@ -10,17 +10,20 @@ PORTVERSION= 2.28
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
http://wwwx.netheaven.com/~coopercc/xmlparser/
-MASTER_SITE_SUBDIR= ../by-authors/id/C/CO/COOPERCL
+MASTER_SITE_SUBDIR= XML
PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
-USE_PERL5= YES
+USE_PERL5= yes
MAN3= XML::Parser.3 XML::Parser::Expat.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS}"
+ @${PERL} -i -pe 's/^(CC = ).*/$$1 ${CC}/;' \
+ -e 's/^(CCFLAGS = ).*/$$1 ${CFLAGS}/' ${WRKSRC}/Expat/Makefile
.include <bsd.port.mk>