aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-RSS/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-XML-RSS/Makefile')
-rw-r--r--textproc/p5-XML-RSS/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/textproc/p5-XML-RSS/Makefile b/textproc/p5-XML-RSS/Makefile
new file mode 100644
index 000000000000..088f368d68c1
--- /dev/null
+++ b/textproc/p5-XML-RSS/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: XML::RSS
+# Date created: 4th September 2000
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-RSS
+PORTVERSION= 0.9
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ade@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/Parser/Expat.pm:${PORTSDIR}/textproc/p5-XML-Parser
+
+USE_PERL5= yes
+
+MAN3= XML::RSS.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS}"
+
+.include <bsd.port.mk>