aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-XPathEngine/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-XML-XPathEngine/Makefile')
-rw-r--r--textproc/p5-XML-XPathEngine/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/textproc/p5-XML-XPathEngine/Makefile b/textproc/p5-XML-XPathEngine/Makefile
index e56eb34ae1cd..aa6811efa1e0 100644
--- a/textproc/p5-XML-XPathEngine/Makefile
+++ b/textproc/p5-XML-XPathEngine/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= XML-XPathEngine
-PORTVERSION= 0.11
+PORTVERSION= 0.12
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -20,4 +20,10 @@ MAN3= XML::XPathEngine.3 XML::XPathEngine::Boolean.3 \
XML::XPathEngine::Literal.3 XML::XPathEngine::NodeSet.3 \
XML::XPathEngine::Number.3
+# For errors like
+# Bareword "XML::XPathEngine::Step::..." not allowed while "strict subs" in use at ...
+post-patch:
+ ${REINPLACE_CMD} -Ee 's,(use strict;),\1 no strict "subs";,' ${WRKSRC}/lib/XML/XPathEngine.pm
+ ${RM} ${WRKSRC}/lib/XML/XPathEngine.pm.bak
+
.include <bsd.port.mk>