aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-YAML/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-YAML/Makefile')
-rw-r--r--textproc/p5-YAML/Makefile45
1 files changed, 32 insertions, 13 deletions
diff --git a/textproc/p5-YAML/Makefile b/textproc/p5-YAML/Makefile
index 633912f1c0db..107e936f6577 100644
--- a/textproc/p5-YAML/Makefile
+++ b/textproc/p5-YAML/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= YAML
-PORTVERSION= 0.39
+PORTVERSION= 0.50
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= YAML
@@ -15,25 +15,44 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= YAML implementation in Perl
+BUILD_DEPENDS= \
+ p5-Spiffy>=0.25:${PORTSDIR}/devel/p5-Spiffy \
+ p5-Test-Base>=0.45:${PORTSDIR}/devel/p5-Test-Base
+
PERL_CONFIGURE= yes
CONFIGURE_ARGS+= </dev/null
-MAN1= ysh.1
-MAN3= YAML.3 YAML::Node.3
+MAN1= ysh.1
+MAN3= \
+ YAML.3 \
+ YAML::Base.3 \
+ YAML::Dumper.3 \
+ YAML::Dumper::Base.3 \
+ YAML::Error.3 \
+ YAML::Loader.3 \
+ YAML::Loader::Base.3 \
+ YAML::Marshall.3 \
+ YAML::Node.3 \
+ YAML::Tag.3 \
+ YAML::Types.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500600
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.1 or later. Install lang/perl5.8 and try again
+.endif
+
+.if ${PERL_LEVEL} < 500803
post-install:
- @${ECHO} ""
- @${ECHO} "You are using an old version of Perl."
- @${ECHO} ""
- @${ECHO} "YAML.pm module is known to be buggy with your"
- @${ECHO} "version of Perl. It should mostly work, but"
- @${ECHO} "it will not be able to dump Perl code correctly."
- @${ECHO} ""
- @${ECHO} "Perhaps you should consider an upgrade."
- @${ECHO} ""
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "===> You are using an old version of Perl."
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "===> YAML.pm module is known to be buggy with your"
+ @${ECHO_MSG} "===> version of Perl. It should mostly work, but"
+ @${ECHO_MSG} "===> it will not be able to dump Perl code correctly."
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "===> Perhaps you should consider an upgrade."
+ @${ECHO_MSG} ""
.endif
.include <bsd.port.post.mk>