aboutsummaryrefslogtreecommitdiff
path: root/textproc/pear-XML_DTD/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/pear-XML_DTD/Makefile')
-rw-r--r--textproc/pear-XML_DTD/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/textproc/pear-XML_DTD/Makefile b/textproc/pear-XML_DTD/Makefile
new file mode 100644
index 000000000000..6a693424b2ad
--- /dev/null
+++ b/textproc/pear-XML_DTD/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: pear-XML_DTD
+# Date created: 2006/07/31
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML_DTD
+PORTVERSION= 0.4.2
+CATEGORIES= textproc devel pear
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= Parsing of DTD files and DTD validation of XML files
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
+ ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_DOS2UNIX= yes
+
+CATEGORY= XML
+FILES= DTD/XmlValidator.php DTD.php
+TESTS= attributes.dtd attributes_bad.xml attributes_good.xml \
+ children.dtd children_bad.xml children_good.xml \
+ content.dtd content_bad.xml content_good.xml \
+ nitf-3-1.dtd nitf-fishing.xml package-1.0 package-1.1.dtd \
+ test.php TOTEST xhtml1-strict.dtd
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>