aboutsummaryrefslogtreecommitdiff
path: root/textproc/pecl-xdiff/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/pecl-xdiff/Makefile')
-rw-r--r--textproc/pecl-xdiff/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/textproc/pecl-xdiff/Makefile b/textproc/pecl-xdiff/Makefile
new file mode 100644
index 000000000000..57ac3c2448c2
--- /dev/null
+++ b/textproc/pecl-xdiff/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: pecl-xdiff
+# Date created: 19 April 2006
+# Whom: Larry Rosenman <ler@lerctr.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xdiff
+PORTVERSION= 1.4
+CATEGORIES= textproc pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= ler@lerctr.org
+COMMENT= A PECL extension to create/apply binary and text patches
+
+LIB_DEPENDS= xdiff.0:${PORTSDIR}/textproc/libxdiff
+
+USE_PHP= yes
+USE_PHPEXT= yes
+
+post-configure:
+ echo "#define HAVE_XDL_ALLOCATOR_PRIV 1" >>${WRKSRC}/config.h
+.include <bsd.port.mk>