aboutsummaryrefslogtreecommitdiff
path: root/textproc/pootle/files/patch-setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/pootle/files/patch-setup.py')
-rw-r--r--textproc/pootle/files/patch-setup.py13
1 files changed, 7 insertions, 6 deletions
diff --git a/textproc/pootle/files/patch-setup.py b/textproc/pootle/files/patch-setup.py
index 37ed22345c95..73901eaca0d9 100644
--- a/textproc/pootle/files/patch-setup.py
+++ b/textproc/pootle/files/patch-setup.py
@@ -1,24 +1,25 @@
---- setup.py 2009-12-17 13:56:51.000000000 +0300
-+++ setup.py 2009-12-17 13:57:06.000000000 +0300
-@@ -54,10 +54,10 @@
+--- setup.py.orig 2009-12-02 07:33:29.000000000 -0200
++++ setup.py 2010-04-01 17:34:44.000000000 -0300
+@@ -54,10 +54,9 @@
It uses the Translate Toolkit to get access to translation files and therefore
can edit a variety of files (including PO and XLIFF files)."""
-INSTALL_CONFIG_DIR = '/etc/pootle'
+INSTALL_CONFIG_DIR = 'etc/pootle'
INSTALL_DATA_DIR = 'share/pootle'
- INSTALL_DOC_DIR = 'share/doc/pootle'
+-INSTALL_DOC_DIR = 'share/doc/pootle'
-INSTALL_WORKING_DIR = '/var/lib/pootle'
+INSTALL_WORKING_DIR = '/var/db/pootle'
###############################################################################
# HELPER FUNCTIONS
-@@ -65,7 +65,7 @@
+@@ -65,8 +64,7 @@
def collect_options():
data_files = [
- (INSTALL_CONFIG_DIR, ['localsettings.py']),
+- (INSTALL_DOC_DIR, ['wsgi.py', 'ChangeLog', 'COPYING', 'README', 'INSTALL']),
+ (INSTALL_CONFIG_DIR, ['localsettings.py.sample']),
- (INSTALL_DOC_DIR, ['wsgi.py', 'ChangeLog', 'COPYING', 'README', 'INSTALL']),
(INSTALL_WORKING_DIR + '/dbs', []) # Create the empty "dbs" dir
] + list_tree(INSTALL_DATA_DIR, 'templates') + list_tree(INSTALL_DATA_DIR, 'html') + \
+ list_tree(INSTALL_WORKING_DIR, 'po') + list_tree(INSTALL_DATA_DIR, 'mo')