aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-feedparser
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/py-feedparser')
-rw-r--r--textproc/py-feedparser/Makefile32
-rw-r--r--textproc/py-feedparser/distinfo2
-rw-r--r--textproc/py-feedparser/pkg-descr5
3 files changed, 39 insertions, 0 deletions
diff --git a/textproc/py-feedparser/Makefile b/textproc/py-feedparser/Makefile
new file mode 100644
index 000000000000..0dc56a488aff
--- /dev/null
+++ b/textproc/py-feedparser/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: feedparser
+# Date created: Mar 11, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= feedparser
+PORTVERSION= 2.76
+CATEGORIES= textproc python
+MASTER_SITES= http://diveintomark.org/projects/feed_parser/
+EXTRACT_SUFX= .py
+DISTNAME= ${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= An RSS feed parser
+
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS= #
+EXTRACT_AFTER_ARGS= .
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PYTHON= yes
+
+PLIST_FILES= ${PYTHON_SITELIBDIR:S,^${PREFIX}/,,}/${PORTNAME}.py
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.py ${PYTHON_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/py-feedparser/distinfo b/textproc/py-feedparser/distinfo
new file mode 100644
index 000000000000..c089ef76796f
--- /dev/null
+++ b/textproc/py-feedparser/distinfo
@@ -0,0 +1,2 @@
+MD5 (feedparser.py) = b233c80826705aacaab5b50819b277e7
+SIZE (feedparser.py) = 57429
diff --git a/textproc/py-feedparser/pkg-descr b/textproc/py-feedparser/pkg-descr
new file mode 100644
index 000000000000..414bc24e5577
--- /dev/null
+++ b/textproc/py-feedparser/pkg-descr
@@ -0,0 +1,5 @@
+This is a "universal" feed parser, suitable for reading syndicated feeds as
+produced by weblogs, news sites, wikis, and many other types of sites. It
+handles Atom feeds, and the 9 different versions of RSS.
+
+WWW: http://diveintomark.org/projects/feed_parser/