aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-genshi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/py-genshi/Makefile')
-rw-r--r--textproc/py-genshi/Makefile29
1 files changed, 20 insertions, 9 deletions
diff --git a/textproc/py-genshi/Makefile b/textproc/py-genshi/Makefile
index adcf78ce8d0e..c6552e551ba1 100644
--- a/textproc/py-genshi/Makefile
+++ b/textproc/py-genshi/Makefile
@@ -2,24 +2,35 @@
# $FreeBSD$
PORTNAME= Genshi
-PORTVERSION= 0.7
-PORTREVISION= 2
-#PORTEPOCH= 0
+PORTVERSION= 0.7.3
CATEGORIES= textproc www python
-MASTER_SITES= http://ftp.edgewall.com/pub/${PORTNAME:tl}/
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= nivit@FreeBSD.org
-COMMENT= Python toolkit for stream-based generation of output for the web
+COMMENT= Toolkit for generation of output for the web
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= python
+USE_PYTHON= distutils autoplist
OPTIONS_DEFINE= BABEL
BABEL_DESC= I18n support through the Babel plugin
-USES= python
-USE_PYTHON= distutils autoplist
+BABEL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>=0.8:devel/py-babel@${PY_FLAVOR}
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.pre.mk>
-BABEL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>=0.9.6:devel/py-babel@${PY_FLAVOR}
+.if ${PYTHON_VER} < 3.3
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/genshi/*.so
+.else
+NO_ARCH= yes
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>