aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-genshi/files/patch-setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/py-genshi/files/patch-setup.py')
-rw-r--r--textproc/py-genshi/files/patch-setup.py17
1 files changed, 0 insertions, 17 deletions
diff --git a/textproc/py-genshi/files/patch-setup.py b/textproc/py-genshi/files/patch-setup.py
deleted file mode 100644
index 57166f1c6c15..000000000000
--- a/textproc/py-genshi/files/patch-setup.py
+++ /dev/null
@@ -1,17 +0,0 @@
---- setup.py.orig 2013-01-27 15:48:03 UTC
-+++ setup.py
-@@ -65,9 +65,13 @@ available.""")
-
-
- if Feature:
-+ # Optional C extension module for speeding up Genshi:
-+ # Not activated by default on:
-+ # - PyPy (where it harms performance)
-+ # - CPython >= 3.3 (the new Unicode C API is not supported yet)
- speedups = Feature(
- "optional C speed-enhancements",
-- standard = not is_pypy,
-+ standard = not is_pypy and sys.version_info < (3, 3),
- ext_modules = [
- Extension('genshi._speedups', ['genshi/_speedups.c']),
- ],