aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-rdflib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/py-rdflib/Makefile')
-rw-r--r--textproc/py-rdflib/Makefile23
1 files changed, 3 insertions, 20 deletions
diff --git a/textproc/py-rdflib/Makefile b/textproc/py-rdflib/Makefile
index a97187ad8a2e..ac5367fac424 100644
--- a/textproc/py-rdflib/Makefile
+++ b/textproc/py-rdflib/Makefile
@@ -15,25 +15,8 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= python@FreeBSD.org
COMMENT= A Python library for RDF manipulation
-BUILD_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
-RUN_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
-
USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-
-PYRDFLIB_EGG= ${PORTNAME}-${PORTVERSION}-py${PYTHON_VER}-${OSINFOS}.egg
-OSINFOS= ${OPSYS:L}-${OSRELEASE}-${ARCH}
-
-PLIST_SUB+= PYRDFLIB_EGG=${PYRDFLIB_EGG}
-
-pre-build:
- @cd ${WRKSRC} && ${PYTHON_CMD} setup.py setopt -c build -o build-platlib -s lib.${OSINFOS}
- @cd ${WRKSRC} && ${PYTHON_CMD} setup.py setopt -c build -o build-temp -s temp.${OSINFOS}-${PYTHON_VER}
- @cd ${WRKSRC} && ${PYTHON_CMD} setup.py setopt -c bdist_egg -o plat-name -s ${OSINFOS}
- @cd ${WRKSRC} && ${PYTHON_CMD} setup.py setopt -c bdist -o plat-name -s ${OSINFOS}
-
-.include <bsd.port.pre.mk>
-
-OSRELEASE!= uname -r
+USE_PYDISTUTILS= easy_install
+PYEASYINSTALL_ARCHDEP= yes
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>