aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-snowballstemmer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/py-snowballstemmer/Makefile')
-rw-r--r--textproc/py-snowballstemmer/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/textproc/py-snowballstemmer/Makefile b/textproc/py-snowballstemmer/Makefile
index fdd1d18231ef..fcb092ca1972 100644
--- a/textproc/py-snowballstemmer/Makefile
+++ b/textproc/py-snowballstemmer/Makefile
@@ -2,16 +2,27 @@
PORTNAME= snowballstemmer
PORTVERSION= 1.2.0
+PORTREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= kmoore@FreeBSD.org
-COMMENT= Pure Python stemming library
+COMMENT= Snowball stemming library collection for Python
-LICENSE= MIT
+LICENSE= BSD2CLAUSE
USES= python
USE_PYTHON= distutils autoplist
+OPTIONS_DEFINE= PYSTEMMER
+OPTIONS_DEFAULT=PYSTEMMER
+PYSTEMMER_DESC= Use PyStemmer to accelerate
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MPYSTEMMER}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pystemmer>0:${PORTSDIR}/textproc/py-pystemmer
+.endif
+
.include <bsd.port.mk>