aboutsummaryrefslogtreecommitdiff
path: root/textproc/raptor2
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/raptor2')
-rw-r--r--textproc/raptor2/Makefile36
-rw-r--r--textproc/raptor2/distinfo3
-rw-r--r--textproc/raptor2/files/patch-configure178
-rw-r--r--textproc/raptor2/pkg-descr6
-rw-r--r--textproc/raptor2/pkg-plist85
5 files changed, 0 insertions, 308 deletions
diff --git a/textproc/raptor2/Makefile b/textproc/raptor2/Makefile
deleted file mode 100644
index fe9c99811de0..000000000000
--- a/textproc/raptor2/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-# ex:ts=8
-# New ports collection makefile for: raptor
-# Date created: Nov 22, 2001
-# Whom: ijliao
-#
-# $FreeBSD$
-#
-
-PORTNAME= raptor
-PORTVERSION= 1.4.13
-PORTREVISION= 1
-CATEGORIES= textproc
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- http://download.librdf.org/source/
-MASTER_SITE_SUBDIR= librdf
-
-MAINTAINER= chuck@pkix.net
-COMMENT= RDF Parser Toolkit for Redland
-
-LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl
-
-USE_GNOME= gnomehack gnometarget libxml2
-USE_GETOPT_LONG= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-xml2-config=${LOCALBASE}/bin/xml2-config \
- --with-curl-config=${LOCALBASE}/bin/curl-config \
- --with-pkg-config=${LOCALBASE}/bin/pkg-config \
- --with-xml-parser=libxml --with-www=curl \
- --mandir=${PREFIX}/man
-
-USE_LDCONFIG= yes
-
-MAN1= rapper.1 raptor-config.1
-MAN3= libraptor.3
-
-.include <bsd.port.mk>
diff --git a/textproc/raptor2/distinfo b/textproc/raptor2/distinfo
deleted file mode 100644
index 8583eadf1ad8..000000000000
--- a/textproc/raptor2/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (raptor-1.4.13.tar.gz) = a00b9685dd42d29537a4ff6bc94efabd
-SHA256 (raptor-1.4.13.tar.gz) = f017a49515e19527914770e8659e7b1a487ee829bf85d6698fdf25ef81883533
-SIZE (raptor-1.4.13.tar.gz) = 1412413
diff --git a/textproc/raptor2/files/patch-configure b/textproc/raptor2/files/patch-configure
deleted file mode 100644
index 9501209fda7c..000000000000
--- a/textproc/raptor2/files/patch-configure
+++ /dev/null
@@ -1,178 +0,0 @@
---- configure.orig Mon Dec 11 15:16:01 2006
-+++ configure Mon Dec 11 15:28:29 2006
-@@ -19868,6 +19868,74 @@
-
-
-
-+# Check whether --with-curl-config was given.
-+if test "${with_curl_config+set}" = set; then
-+ withval=$with_curl_config; curl_config="$withval"
-+else
-+ curl_config=""
-+fi
-+
-+
-+if test "X$curl_config" != "X" ; then
-+ { echo "$as_me:$LINENO: checking for $curl_config" >&5
-+echo $ECHO_N "checking for $curl_config... $ECHO_C" >&6; }
-+
-+ if test -f $curl_config ; then
-+ CURL_CONFIG=$curl_config
-+ { echo "$as_me:$LINENO: result: yes" >&5
-+echo "${ECHO_T}yes" >&6; }
-+ else
-+ { echo "$as_me:$LINENO: result: no - searching PATH" >&5
-+echo "${ECHO_T}no - searching PATH" >&6; }
-+ fi
-+fi
-+if test "X$CURL_CONFIG" = "X"; then
-+ for ac_prog in curl-config
-+do
-+ # Extract the first word of "$ac_prog", so it can be a program name with args.
-+set dummy $ac_prog; ac_word=$2
-+{ echo "$as_me:$LINENO: checking for $ac_word" >&5
-+echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
-+if test "${ac_cv_prog_CURL_CONFIG+set}" = set; then
-+ echo $ECHO_N "(cached) $ECHO_C" >&6
-+else
-+ if test -n "$CURL_CONFIG"; then
-+ ac_cv_prog_CURL_CONFIG="$CURL_CONFIG" # Let the user override the test.
-+else
-+as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
-+for as_dir in $PATH
-+do
-+ IFS=$as_save_IFS
-+ test -z "$as_dir" && as_dir=.
-+ for ac_exec_ext in '' $ac_executable_extensions; do
-+ if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; }; then
-+ ac_cv_prog_CURL_CONFIG="$ac_prog"
-+ echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
-+ break 2
-+ fi
-+done
-+done
-+IFS=$as_save_IFS
-+
-+fi
-+fi
-+CURL_CONFIG=$ac_cv_prog_CURL_CONFIG
-+if test -n "$CURL_CONFIG"; then
-+ { echo "$as_me:$LINENO: result: $CURL_CONFIG" >&5
-+echo "${ECHO_T}$CURL_CONFIG" >&6; }
-+else
-+ { echo "$as_me:$LINENO: result: no" >&5
-+echo "${ECHO_T}no" >&6; }
-+fi
-+
-+
-+ test -n "$CURL_CONFIG" && break
-+done
-+
-+fi
-+
-+oCPPFLAGS="$CPPFLAGS"
-+CPPFLAGS="$CPPFLAGS `$CURL_CONFIG --cflags`"
-
- for ac_header in errno.h stdlib.h unistd.h string.h limits.h dmalloc.h getopt.h sys/stat.h curl/curl.h libxml/nanohttp.h sys/param.h sys/time.h
- do
-@@ -20037,6 +20105,9 @@
-
- done
-
-+CPPFLAGS="$oCPPFLAGS"
-+LIBS="$oLIBS"
-+
- { echo "$as_me:$LINENO: checking whether time.h and sys/time.h may both be included" >&5
- echo $ECHO_N "checking whether time.h and sys/time.h may both be included... $ECHO_C" >&6; }
- if test "${ac_cv_header_time+set}" = set; then
-@@ -23931,72 +24002,6 @@
- fi
-
-
--# Check whether --with-curl-config was given.
--if test "${with_curl_config+set}" = set; then
-- withval=$with_curl_config; curl_config="$withval"
--else
-- curl_config=""
--fi
--
--
--if test "X$curl_config" != "X" ; then
-- { echo "$as_me:$LINENO: checking for $curl_config" >&5
--echo $ECHO_N "checking for $curl_config... $ECHO_C" >&6; }
--
-- if test -f $curl_config ; then
-- CURL_CONFIG=$curl_config
-- { echo "$as_me:$LINENO: result: yes" >&5
--echo "${ECHO_T}yes" >&6; }
-- else
-- { echo "$as_me:$LINENO: result: no - searching PATH" >&5
--echo "${ECHO_T}no - searching PATH" >&6; }
-- fi
--fi
--if test "X$CURL_CONFIG" = "X"; then
-- for ac_prog in curl-config
--do
-- # Extract the first word of "$ac_prog", so it can be a program name with args.
--set dummy $ac_prog; ac_word=$2
--{ echo "$as_me:$LINENO: checking for $ac_word" >&5
--echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
--if test "${ac_cv_prog_CURL_CONFIG+set}" = set; then
-- echo $ECHO_N "(cached) $ECHO_C" >&6
--else
-- if test -n "$CURL_CONFIG"; then
-- ac_cv_prog_CURL_CONFIG="$CURL_CONFIG" # Let the user override the test.
--else
--as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
--for as_dir in $PATH
--do
-- IFS=$as_save_IFS
-- test -z "$as_dir" && as_dir=.
-- for ac_exec_ext in '' $ac_executable_extensions; do
-- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; }; then
-- ac_cv_prog_CURL_CONFIG="$ac_prog"
-- echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
-- break 2
-- fi
--done
--done
--IFS=$as_save_IFS
--
--fi
--fi
--CURL_CONFIG=$ac_cv_prog_CURL_CONFIG
--if test -n "$CURL_CONFIG"; then
-- { echo "$as_me:$LINENO: result: $CURL_CONFIG" >&5
--echo "${ECHO_T}$CURL_CONFIG" >&6; }
--else
-- { echo "$as_me:$LINENO: result: no" >&5
--echo "${ECHO_T}no" >&6; }
--fi
--
--
-- test -n "$CURL_CONFIG" && break
--done
--
--fi
--
-
- oLIBS="$LIBS"
-
-@@ -25623,7 +25628,9 @@
-
- oCPPFLAGS="$CPPFLAGS"
- if test "X$CURL_CONFIG" != X; then
-+ oCPPFLAGS="$CPPFLAGS"
- oLIBS="$LIBS"
-+ CPPFLAGS="$CPPFLAGS `$CURL_CONFIG --cflags`"
- LIBS="$LIBS `$CURL_CONFIG --libs`"
- { echo "$as_me:$LINENO: checking for curl_easy_init" >&5
- echo $ECHO_N "checking for curl_easy_init... $ECHO_C" >&6; }
-@@ -25728,6 +25735,7 @@
- have_curl_easy_init=no
- fi
-
-+ CPPFLAGS="$oCPPFLAGS"
- LIBS="$oLIBS"
- { echo "$as_me:$LINENO: checking for libcurl library" >&5
- echo $ECHO_N "checking for libcurl library... $ECHO_C" >&6; }
diff --git a/textproc/raptor2/pkg-descr b/textproc/raptor2/pkg-descr
deleted file mode 100644
index 3554b87cb0a8..000000000000
--- a/textproc/raptor2/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-Raptor is the RDF Parser Toolkit for Redland and currently consists of two
-parsers: RDF/XML and N-Triples. Raptor is designed to integrate closely
-with Redland and also work entirely standalone, in which case it will use
-simple internal routines to perform the functions.
-
-WWW: http://librdf.org/raptor/
diff --git a/textproc/raptor2/pkg-plist b/textproc/raptor2/pkg-plist
deleted file mode 100644
index 03f523c1c52f..000000000000
--- a/textproc/raptor2/pkg-plist
+++ /dev/null
@@ -1,85 +0,0 @@
-bin/rapper
-bin/raptor-config
-include/raptor.h
-lib/libraptor.a
-lib/libraptor.la
-lib/libraptor.so
-lib/libraptor.so.2
-libdata/pkgconfig/raptor.pc
-@exec mkdir -p %D/share/gtk-doc/html/raptor
-share/gtk-doc/html/raptor/home.png
-share/gtk-doc/html/raptor/index.html
-share/gtk-doc/html/raptor/index.sgml
-share/gtk-doc/html/raptor/introduction.html
-share/gtk-doc/html/raptor/ix01.html
-share/gtk-doc/html/raptor/left.png
-share/gtk-doc/html/raptor/parser-grddl.html
-share/gtk-doc/html/raptor/parser-guess.html
-share/gtk-doc/html/raptor/parser-ntriples.html
-share/gtk-doc/html/raptor/parser-rdfxml.html
-share/gtk-doc/html/raptor/parser-rss-tag-soup.html
-share/gtk-doc/html/raptor/parser-turtle.html
-share/gtk-doc/html/raptor/raptor.devhelp
-share/gtk-doc/html/raptor/raptor.devhelp2
-share/gtk-doc/html/raptor/raptor-parsers.html
-share/gtk-doc/html/raptor/raptor-section-constants.html
-share/gtk-doc/html/raptor/raptor-section-feature.html
-share/gtk-doc/html/raptor/raptor-section-general.html
-share/gtk-doc/html/raptor/raptor-section-iostream.html
-share/gtk-doc/html/raptor/raptor-section-locator.html
-share/gtk-doc/html/raptor/raptor-section-memory.html
-share/gtk-doc/html/raptor/raptor-section-parser.html
-share/gtk-doc/html/raptor/raptor-section-sequence.html
-share/gtk-doc/html/raptor/raptor-section-serializer.html
-share/gtk-doc/html/raptor/raptor-serializers.html
-share/gtk-doc/html/raptor/raptor-section-stringbuffer.html
-share/gtk-doc/html/raptor/raptor-section-triples.html
-share/gtk-doc/html/raptor/raptor-section-unicode.html
-share/gtk-doc/html/raptor/raptor-section-uri-factory.html
-share/gtk-doc/html/raptor/raptor-section-uri.html
-share/gtk-doc/html/raptor/raptor-section-www.html
-share/gtk-doc/html/raptor/raptor-section-xml-namespace.html
-share/gtk-doc/html/raptor/raptor-section-xml-qname.html
-share/gtk-doc/html/raptor/raptor-section-xml.html
-share/gtk-doc/html/raptor/reference-manual.html
-share/gtk-doc/html/raptor/restrict-parser-network-access.html
-share/gtk-doc/html/raptor/right.png
-share/gtk-doc/html/raptor/serializer-atom.html
-share/gtk-doc/html/raptor/serializer-ntriples.html
-share/gtk-doc/html/raptor/serializer-rdfxml-abbrev.html
-share/gtk-doc/html/raptor/serializer-rdfxml-xmp.html
-share/gtk-doc/html/raptor/serializer-rdfxml.html
-share/gtk-doc/html/raptor/serializer-rss-1-0.html
-share/gtk-doc/html/raptor/style.css
-share/gtk-doc/html/raptor/tutorial-initialising-finishing.html
-share/gtk-doc/html/raptor/tutorial-serializer-get-triples.html
-share/gtk-doc/html/raptor/tutorial.html
-share/gtk-doc/html/raptor/tutorial-parse-strictness.html
-share/gtk-doc/html/raptor/tutorial-parser-abort.html
-share/gtk-doc/html/raptor/tutorial-parser-content.html
-share/gtk-doc/html/raptor/tutorial-parser-create.html
-share/gtk-doc/html/raptor/tutorial-parser-destroy.html
-share/gtk-doc/html/raptor/tutorial-parser-example.html
-share/gtk-doc/html/raptor/tutorial-parser-features.html
-share/gtk-doc/html/raptor/tutorial-parser-runtime-info.html
-share/gtk-doc/html/raptor/tutorial-parser-set-error-warning-handlers.html
-share/gtk-doc/html/raptor/tutorial-parser-set-id-handler.html
-share/gtk-doc/html/raptor/tutorial-parser-set-namespace-handler.html
-share/gtk-doc/html/raptor/tutorial-parser-static-info.html
-share/gtk-doc/html/raptor/tutorial-parser-set-triple-handler.html
-share/gtk-doc/html/raptor/tutorial-parsing.html
-share/gtk-doc/html/raptor/tutorial-querying-functionality.html
-share/gtk-doc/html/raptor/tutorial-serializer-create.html
-share/gtk-doc/html/raptor/tutorial-serializer-declare-namespace.html
-share/gtk-doc/html/raptor/tutorial-serializer-destroy.html
-share/gtk-doc/html/raptor/tutorial-serializer-example.html
-share/gtk-doc/html/raptor/tutorial-serializer-features.html
-share/gtk-doc/html/raptor/tutorial-serializer-runtime-info.html
-share/gtk-doc/html/raptor/tutorial-serializer-send-triples.html
-share/gtk-doc/html/raptor/tutorial-serializer-set-error-warning-handlers.html
-share/gtk-doc/html/raptor/tutorial-serializer-to-destination.html
-share/gtk-doc/html/raptor/tutorial-serializing.html
-share/gtk-doc/html/raptor/up.png
-@dirrm share/gtk-doc/html/raptor
-@dirrmtry share/gtk-doc/html
-@dirrmtry share/gtk-doc